Bug 1298816 - failed loading cron table
failed loading cron table
Status: CLOSED DUPLICATE of bug 1298192
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-15 02:27 EST by Daniel
Modified: 2016-01-15 08:57 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-15 08:57:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel 2016-01-15 02:27:27 EST
Description of problem: After last bash and kernel update (bash, 4.3.42-3.fc23/kernel 4.2.8-300.fc23 - maybe it's a bash or kernel bug) no cron job will be started anymore if selinux is enforced. This happened on a server which updates itself automaticly and worked untill Jan 13, 2016 normally.

There are a lot of error messages now, like:

nauthorized SELinux context=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 file_context=unconfined_u:object_r:user_cron_spool_t:s0 (/var/spool/cron/root)
 FAILED (loading cron table)

SELinux must be set to permissable if any cron jobs should be executed.
No changes whatsoever were made to the system but the 2 updates of kernel and bash. System worked absolutely until Jan 13, 2016. Only update since then was bash and kernel, x86_64, 4.2.8-300.fc23.

Version-Release number of selected component (if applicable): bash, x86_64, 4.3.42-3.fc23 and kernel, x86_64, 4.2.8-300.fc23


Additional info:

# seinfo -cron_t
ERROR: could not find class ron_t

# sesearch -A -s cron_t 
ERROR: could not find datum for type cron_t

# grep systemd /var/log/audit/audit.log | audit2allow -M mypol
compilation failed:
mypol.te:6:ERROR 'syntax error' at token '' on line 6:
/usr/bin/checkmodule:  error(s) encountered while parsing configuration
/usr/bin/checkmodule:  loading policy configuration from mypol.te
Comment 1 Josh Boyer 2016-01-15 08:57:30 EST

*** This bug has been marked as a duplicate of bug 1298192 ***

Note You need to log in before you can comment on or make changes to this bug.