Bug 1298823 - Wrong commented out syntax in kvm.conf
Wrong commented out syntax in kvm.conf
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-15 03:06 EST by Gianluca Cecchi
Modified: 2016-01-23 22:27 EST (History)
9 users (show)

See Also:
Fixed In Version: qemu-2.4.1-6.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-23 22:27:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gianluca Cecchi 2016-01-15 03:06:45 EST
Description of problem:
In version 2.4.1-4 the file kvm.conf under /etc/modprobe.d was added, but its (actually commented) syntax is wrong, so that if a user simply uncomments one line he/she doesn't get what expected (nested virtualization enablement)

Version-Release number of selected component (if applicable):
2.4.1-5

How reproducible:
Always

Steps to Reproduce:
1. uncomment intel line in /etc/modprobe.d/kvm.conf
2. now you have "option kvm_intel nested=1"
3. dracut -f -v + reboot (or modprobe -r kvm_intel ; modprobe kvm_intel)

Actual results:
systool -a -v -m kvm_intel | grep nested
    nested              = "N"

Expected results:
    nested              = "Y"

Additional info:

If you put the right syntax (with the final "s")
options kvm_intel nested=1
it works as expected

So, even if commented out, the lines should have te right syntax
Comment 1 Cole Robinson 2016-01-15 10:43:56 EST
Thanks for the report, setting to POST since the fix is known, I'll include it in the next build
Comment 2 Fedora Update System 2016-01-21 12:17:01 EST
qemu-2.4.1-6.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-42778e8c82
Comment 3 Fedora Update System 2016-01-21 23:54:34 EST
qemu-2.4.1-6.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-42778e8c82
Comment 4 Fedora Update System 2016-01-23 22:25:16 EST
qemu-2.4.1-6.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.