Bug 1298832 - rdpsnd plugin crashes in specific situations dua a bad sound frame from network
rdpsnd plugin crashes in specific situations dua a bad sound frame from network
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: freerdp (Show other bugs)
7.0
x86_64 Linux
urgent Severity urgent
: rc
: ---
Assigned To: Ondrej Holy
Desktop QE
: ZStream
Depends On: 1210049
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-15 03:46 EST by Jan Kurik
Modified: 2016-02-16 06:18 EST (History)
9 users (show)

See Also:
Fixed In Version: freerdp-1.0.2-6.el7.1
Doc Type: Bug Fix
Doc Text:
Previously, pulseaudio structures were not accessed exclusively. As aconsequence, the xfreerdp client could terminate unexpectedly when soundredirection using pulseaudio was enabled. A missing lock has been added toensure exclusive access for pulseaudio structures, and the xfreerdp clientno longer crashes in this situation.
Story Points: ---
Clone Of: 1210049
Environment:
Last Closed: 2016-02-16 06:18:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1054987 None None None 2016-01-15 03:47 EST

  None (edit)
Description Jan Kurik 2016-01-15 03:46:54 EST
This bug has been copied from bug #1210049 and has been proposed
to be backported to 7.2 z-stream (EUS).
Comment 5 errata-xmlrpc 2016-02-16 06:18:32 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0215.html

Note You need to log in before you can comment on or make changes to this bug.