Bug 1298845 - [RFE] Simplified replica installation - replica promotion
[RFE] Simplified replica installation - replica promotion
Status: CLOSED DUPLICATE of bug 837369
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.2
Unspecified Unspecified
high Severity medium
: rc
: ---
Assigned To: IPA Maintainers
Namita Soman
: FutureFeature
Depends On:
Blocks: 1292074 1296125
  Show dependency treegraph
 
Reported: 2016-01-15 04:15 EST by Petr Vobornik
Modified: 2016-02-19 07:40 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-19 07:40:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Vobornik 2016-01-15 04:15:47 EST
The current method to install a replica requires a 2 phases approach where an admin physically logs into a master and generates an installation package, then transfers it to a new server and performs the replica install procedure. This method is cumbersome, require interaction (the ipa-replica-prepare command wants the Directory Manager password) and is generally hard to deal with in an automated fashion. A new method to promote a regular client to a replica and in general simplify replica installs will make a number of maintenance operations easier. A new replica promotion sequence will allow easier provisioning via an external infrastructure management system, while retaining a reasonable level of security (or increasing the security of the solution in some areas). 

Usage:
As an Administrator I want to deploy my multi master IdM Server infrastructure cluster using deployment tools of my choice (Ansible, Puppet, Foreman...) without leaking the IdM passwords to the infrastructure so that they do not end up in any answer file or argument database. The installation scripts should not require interactive logging to the target replica or copying of any file on the server.
Comment 3 Petr Vobornik 2016-02-19 07:40:28 EST

*** This bug has been marked as a duplicate of bug 837369 ***

Note You need to log in before you can comment on or make changes to this bug.