Bug 1298846 - Some resources like pvc or template cannot be deleted via oc delete all --all
Some resources like pvc or template cannot be deleted via oc delete all --all
Status: CLOSED NOTABUG
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
3.x
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Juan Vallejo
Wei Sun
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-15 04:20 EST by Wenjing Zheng
Modified: 2016-08-04 09:54 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-04 09:54:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wenjing Zheng 2016-01-15 04:20:41 EST
Description of problem:
Some resources like pvc or template cannot be deleted via oc delete all --all:
[root@ip-172-18-15-30 ~]# oc process -f https://raw.githubusercontent.com/openshift/mysql/master/5.5/examples/replica/mysql_replica.json | oc create -f -
persistentvolumeclaim "mysql-master" created
service "mysql-master" created
service "mysql-slave" created
deploymentconfig "mysql-master" created
deploymentconfig "mysql-slave" created

[root@ip-172-18-15-30 ~]# oc delete all --all
deploymentconfig "mysql-master" deleted
deploymentconfig "mysql-slave" deleted
service "mysql-master" deleted
service "mysql-slave" deleted
pod "mysql-slave-1-03e3c" deleted

Version-Release number of selected component (if applicable):
oc v1.1-793-gfa7cfe6
kubernetes v1.1.0-origin-1107-g4c8e6f4

How reproducible:
always

Steps to Reproduce:
1. Create a project
2. Create resources contained pvc
3. Delete all via oc delete all --all

Actual results:
pvc is not deleted.

Expected results:
pvc should also be deleted along with other resources.

Additional info:
Same for template
Comment 1 Wenjing Zheng 2016-01-15 04:25:34 EST
According to the output of "oc status", all seems mean everything:
list everything with 'oc get all'

However, "oc get all" cannot list pvc or template either like "oc delete all". There is no define in "oc delete" help page, it's better to define what resources are included in this "all".
Comment 2 Xia Zhao 2016-04-12 06:03:53 EDT
Issue exist when doing "oc get all". pvc and template can not be listed by this way.
Comment 3 Juan Vallejo 2016-08-04 09:54:38 EDT
This is not a bug, per this discussion [1] and this explanation by David Eads [2], PVCs / templates not showing up and not being deleted by `oc get all --all` are intended behavior.

[1] https://github.com/kubernetes/kubernetes/pull/28955
[2] https://github.com/openshift/origin/issues/10185#issuecomment-237548071

Note You need to log in before you can comment on or make changes to this bug.