Bug 12989 - Updated e1000 driver needed
Updated e1000 driver needed
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-24 09:39 EDT by Becky Miller
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-08 09:56:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
e1000 v2.0.6 driver (280.00 KB, application/octet-stream)
2000-07-21 14:46 EDT, Matt Domsch
no flags Details

  None (edit)
Description Becky Miller 2000-06-24 09:39:17 EDT
The latest version of the Intel E1000 driver version is 2.0.6
This needs to be included in the kernel.
Comment 1 Matt Domsch 2000-07-21 14:46:56 EDT
Created attachment 1428 [details]
e1000 v2.0.6 driver
Comment 2 Matt Domsch 2000-07-21 14:47:46 EDT
v1.0.3 is in kernel 2.2.16-12 on Winston Beta 4.  v2.0.6 is now attached to 
this bug.
Comment 3 Michael K. Johnson 2000-08-01 18:05:07 EDT
Alan, is this something that should be sucked into official kernels?
I see that they added a few extra files and do not have a Makefile
patch or anything intelligent like that... :-/
Comment 4 Alan Cox 2000-08-01 18:15:16 EDT
Neither E100 or E1000 will go into the mainstream 2.2 or 2.4 kernel until Intel
are prepared to give us either a GPL licensed copy or a piece of paper saying
they will not suddenly spring suprise patent claims on users of the driver after
we distribute it.

There are technical reasons for not including E100 (its crap) and E1000 needs a
good clean up but the current holdup is licensing issues and protection against
Intel springing unpleasant traps on companies. (Several of whom interestingly
specifically named this as a worry and named intel as the people they thought
would try it)

Are legal on bugzilla 8)
Comment 5 Michael K. Johnson 2000-08-02 12:35:08 EDT
No, but I spoke to legal, and legal is deeply troubled by the
lack of a patent grant and thinks that without an explicit grant
of some sort, we really should pull the drivers entirely.
Comment 6 Michael K. Johnson 2000-08-04 10:46:21 EDT
Intel has agreed to make a sufficient patent grant, so
this is now scheduled for inclusion shortly.
Comment 7 Michael K. Johnson 2000-08-04 14:54:38 EDT
It builds.  However, because I had to really hack it into
place to make it build within the kernel as a replacement
for our earlier e1000 driver, I may have broken it, and I
can't tell if that's the case.

We don't have hardware to test it, at least as far as I
am aware.  Becky or Matt, could one of you arrange for
testing it and get back to me?  I'll give you a kernel
with the new driver to test.
Comment 8 Matt Domsch 2000-08-04 14:57:07 EDT
yes, we'll get people testing it ASAP.  Please put the new kernel on gribble 
where we can get to it.
Thanks!
Comment 9 Michael K. Johnson 2000-08-04 17:35:57 EDT
It's now on your private directory on gribble, source and all the
i686 binaries.  Just took a while to build, I guess there was a
lot of other stuff in the build system.
Comment 10 Michael K. Johnson 2000-08-07 15:44:49 EDT
Intel is providing a 2.0.7 version of the driver with the
same code base but changed slightly to patch in easier.
This will keep me from having to mangle the driver before
inserting it into the kernel...

I'm still interested to know whether I broke 2.0.6 while
putting it in place, and we still want to test it in case
Intel runs into unexpected trouble getting 2.0.7 to us in
time, so now I'm asking you to run tests twice.  :-/
Comment 11 Michael K. Johnson 2000-08-07 20:56:42 EDT
The 2.0.7 version is integrated.  Matt,
I'll give you a new kernel sometime
tomorrow.
Comment 12 Michael K. Johnson 2000-08-08 09:56:07 EDT
Matt, the 2.2.16-19.1 kernel on gribble has the
updated driver for you to test.  Thanks!
Comment 13 Michael K. Johnson 2000-08-09 13:00:02 EDT
Since it is integrated, I'm closing the bug.  If
you find a bug in the driver, open a new bug...

Thanks!

Note You need to log in before you can comment on or make changes to this bug.