Bug 1298904 - mhoarch doesn't run
mhoarch doesn't run
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mhonarc (Show other bugs)
23
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: José Matos
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-15 07:07 EST by Nuno Dias
Modified: 2016-08-11 21:23 EDT (History)
4 users (show)

See Also:
Fixed In Version: mhonarc-2.6.19-6.fc24 mhonarc-2.6.19-6.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-11 17:54:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to solve the problem reported (763 bytes, patch)
2016-01-15 07:07 EST, Nuno Dias
no flags Details | Diff

  None (edit)
Description Nuno Dias 2016-01-15 07:07:08 EST
Created attachment 1115104 [details]
Patch to solve the problem reported

Description of problem:
mhoarch doesn't run, I get in the terminal an error, after solve the error,  I get another one.
I attach a patch to solve this problem.

Version-Release number of selected component (if applicable):
mhonarc-2.6.19-1.fc23.noarch

How reproducible:
Every time

Steps to Reproduce:
1. run mhoarch
2.
3.

Actual results:


Expected results:


Additional info:
Can't use 'defined(%hash)' (Maybe you should just omit the defined()?) at /usr/share/MHonArc/mhamain.pl line 1565.
Compilation failed in require at /usr/bin/mhonarc line 39.

Can't use 'defined(%hash)' (Maybe you should just omit the defined()?) at /usr/share/MHonArc/mhopt.pl line 868.
Compilation failed in require at /usr/share/MHonArc/mhamain.pl line 90.
Comment 1 Robin Powell 2016-08-02 20:24:00 EDT
Can someone roll in this patch please?  See also https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=816638
Comment 2 José Matos 2016-08-03 07:12:30 EDT
I am sorry. It was my mistake.

I had evaluated the patch and I was obviously correct but then I assumed I had already applied it. :-(

I am finishing the builds to F23-F26 (rawhide) and I will issue updates to F23 and F24 as soon as the builds are done (missing F23 right now).
Comment 3 Fedora Update System 2016-08-03 08:54:40 EDT
mhonarc-2.6.19-6.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-554242d376
Comment 4 Fedora Update System 2016-08-03 08:55:22 EDT
mhonarc-2.6.19-6.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ff85cae6b4
Comment 5 Xavier Bachelot 2016-08-03 10:46:36 EDT
The part of the patch modifying lib/mhmimetypes.pl seems to be an unrelated change and is neither in the attached patch nor the debian patch.
Comment 6 José Matos 2016-08-03 12:12:05 EDT
That part was included in previous versions and was dropped with the 2.6.19 upgrade, the patch was commented.

This is part of the debian patch:
http://http.debian.net/debian/pool/main/m/mhonarc/mhonarc_2.6.19-2.diff.gz

Actually the fedora has all the non-debian elements of that patch, and that is documented in the spec file:

# Patch based on debian that fixes some issues spotted after 2.6.19 release
Comment 7 Xavier Bachelot 2016-08-03 12:20:06 EDT
Here is a link to the patch as found in current git master : http://pkgs.fedoraproject.org/cgit/rpms/mhonarc.git/plain/mhonarc-2.6.19.patch

The part changing lib/mhmimetypes.pl shouldn't be there.
Comment 8 Fedora Update System 2016-08-03 21:54:26 EDT
mhonarc-2.6.19-6.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-554242d376
Comment 9 Fedora Update System 2016-08-03 21:57:50 EDT
mhonarc-2.6.19-6.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ff85cae6b4
Comment 10 Robin Powell 2016-08-05 20:06:19 EDT
Confirmed working!  Thank you so much!
Comment 11 Fedora Update System 2016-08-11 17:54:50 EDT
mhonarc-2.6.19-6.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2016-08-11 21:23:01 EDT
mhonarc-2.6.19-6.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.