Bug 1298916 - OData v4 - definition of OData-Isolation header is either being ignored or is not implemented corectly
OData v4 - definition of OData-Isolation header is either being ignored or is...
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Teiid (Show other bugs)
6.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ER2
: 6.3.0
Assigned To: Van Halbert
Juraj Duráni
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-15 07:16 EST by Juraj Duráni
Modified: 2017-06-12 11:34 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Teiid - OData v4
Last Closed: 2016-08-24 07:46:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker TEIID-3906 Major Closed OData v4 - definition of OData-Isolation header is either being ignored or is not implemented correctly 2017-06-12 11:34 EDT

  None (edit)
Description Juraj Duráni 2016-01-15 07:16:59 EST
Description of problem:
Teiid does not process header *OData-Isolation: snapshot* defined in request correctly.
* if service (Teiid) does not support this option it must return error 412
* if Teiid does supports this option then it is not processed correctly, because modifications made during request are visbile

See http://docs.oasis-open.org/odata/odata/v4.0/errata02/os/complete/part1-protocol/odata-v4.0-errata02-os-part1-protocol-complete.html#_Toc406398231


Steps to Reproduce:
1. Request [1]
2. Request [2]
3. Data modification via JDBC
4. Request [2]

Data returned from steps 2. and 4. are different.

[1]
Jsoup.connect("http://localhost:8080/odata4/Redshift/Source/SmallA/?$select=IntKey")
                .header("Authorization", "Basic "+ Base64.encodeBytes(("user:user").getBytes()))
                .header("OData-MaxVersion", "4.0")
                .header("Accept", "application/xml")
                .header("OData-Isolation", "snapshot")
                .header("Prefer", "odata.maxpagesize=10")

[2]
Jsoup.connect("http://localhost:8080/odata4/Redshift/Source/SmallA/?$select=IntKey&$skiptoken=+koj1e+zqsMU--10")
                .header("Authorization", "Basic "+ Base64.encodeBytes(("user:user").getBytes()))
                .header("OData-MaxVersion", "4.0")
                .header("Accept", "application/xml")
                .header("Prefer", "odata.maxpagesize=10")
Comment 1 Van Halbert 2016-02-16 13:26:59 EST
Per engineers, deferring till Teiid supports 4.2 Olingo.
Comment 3 JBoss JIRA Server 2016-03-16 19:14:55 EDT
Ramesh Reddy <rareddy@jboss.org> updated the status of jira TEIID-3906 to Coding In Progress
Comment 4 JBoss JIRA Server 2016-03-17 10:06:49 EDT
Ramesh Reddy <rareddy@jboss.org> updated the status of jira TEIID-3906 to Resolved
Comment 5 Van Halbert 2016-03-17 15:37:16 EDT
Due to the issues found with OData, this issue will now be fixed because Teiid will be upgrading Olingo.
Comment 6 JBoss JIRA Server 2016-06-15 08:36:49 EDT
Steven Hawkins <shawkins@redhat.com> updated the status of jira TEIID-3906 to Closed

Note You need to log in before you can comment on or make changes to this bug.