Bug 1298935 - gnome-shell --mode=gdm" takes about 20% cpu
gnome-shell --mode=gdm" takes about 20% cpu
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-15 07:49 EST by adriano
Modified: 2016-02-16 22:49 EST (History)
6 users (show)

See Also:
Fixed In Version: gdm-3.18.2-2.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-16 22:49:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 754814 None None None 2016-02-12 12:27 EST

  None (edit)
Description adriano 2016-01-15 07:49:01 EST
Description of problem:
Each time I start a new gnome session, the process "gnome-shell --mode=gdm" takes about 20% cpu. To stop it, I choose "switch user" from gnome menu and from the gdm panel I enter in my already opened session (same user of previous login).
I  get the same problem start a gnome session with all extensions disabled.

Version-Release number of selected component (if applicable):
gnome-shell-3.18.3-1.fc23.x86_64
Comment 1 Ilja Sekler 2016-02-05 05:58:07 EST
On my hardware this amounts to more than 40% cpu :-( A downgrade to 3.18.1-1.fc23 doesn't help, but I can confirm the workaround.
Comment 2 Ilja Sekler 2016-02-05 08:09:02 EST
FYI: found a much simpler workaround: switch VT to the one where gdm runs then back.

I can't reproduce this bug with i686 on a netbook with Intel graphics, while different fc23.x86_64 installations on different computers equipped with NVIDIA graphics cards using the binary driver exhibit the issue.

@adriano:

Could you please specify which graphics driver you are using?
Comment 3 Sylvain Petreolle 2016-02-06 06:02:22 EST
I get the problem too, with a NVIDIA graphic card (GTX 570) and the proprietary driver.
@Ilja:  I confirm your workaround works.
Comment 4 Ilja Sekler 2016-02-06 08:55:52 EST
Can't reproduce with nouveau, this bug seems to be restricted to the NVIDIA binary driver.
Comment 5 adriano 2016-02-10 05:19:18 EST
(In reply to Ilja Sekler from comment #2)
> FYI: found a much simpler workaround: switch VT to the one where gdm runs
> then back.
> 
> I can't reproduce this bug with i686 on a netbook with Intel graphics, while
> different fc23.x86_64 installations on different computers equipped with
> NVIDIA graphics cards using the binary driver exhibit the issue.
> 
> @adriano:
> 
> Could you please specify which graphics driver you are using?

Yes, I'm using an NVIDIA graphic card.

adriano ~ lspci | grep VGA
01:00.0 VGA compatible controller: NVIDIA Corporation GF119M [NVS 4200M] (rev a1)

NVIDIA proprietary driver from "negativo17 - Nvidia" repo (http://negativo17.org/nvidia-driver/)
Comment 6 Ray Strode [halfline] 2016-02-12 12:27:54 EST
i'm building an update now that should address this.
Comment 7 Ilja Sekler 2016-02-12 13:40:16 EST
(In reply to Ray Strode [halfline] from comment #6)
> i'm building an update now that should address this.

I apologize for bugspam, but I really want to thank you for the immediate backport of the necessary patches. I've grabbed the src.rpm from <http://koji.fedoraproject.org/koji/buildinfo?buildID=735393>, installed the resulting local build and can confirm that it fixes this issue.
Comment 8 Fedora Update System 2016-02-12 13:44:57 EST
gdm-3.18.2-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-6f8f961dc4
Comment 9 Ray Strode [halfline] 2016-02-12 13:45:29 EST
great, if you could put karma on the update, i'd appreciate it.
Comment 10 Sylvain Petreolle 2016-02-13 06:32:37 EST
(In reply to Ray Strode [halfline] from comment #6)
> i'm building an update now that should address this.

What was the problem ?
Comment 11 Fedora Update System 2016-02-15 00:24:32 EST
gdm-3.18.2-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-6f8f961dc4
Comment 12 Ray Strode [halfline] 2016-02-15 11:02:21 EST
(In reply to Sylvain Petreolle from comment #10)
> (In reply to Ray Strode [halfline] from comment #6)
> > i'm building an update now that should address this.
> 
> What was the problem ?

See the linked upstream report for details, but basically an invisible spinner animation had gone rogue.
Comment 13 Fedora Update System 2016-02-16 22:49:15 EST
gdm-3.18.2-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.