Bug 1298961 - include compiled rhel7.0 selinux policy
include compiled rhel7.0 selinux policy
Status: CLOSED NEXTRELEASE
Product: Restraint
Classification: Community
Component: general (Show other bugs)
0.1.21
Unspecified Unspecified
unspecified Severity unspecified
: 0.1.23
: ---
Assigned To: Bill Peck
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-15 09:22 EST by Bill Peck
Modified: 2016-04-20 20:42 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-22 09:38:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Peck 2016-01-15 09:22:10 EST
Description of problem:
rhel7.2 build targets include ppc64le but building against this target uses a newer version of selinux which can't be loaded on older releases.

Version-Release number of selected component (if applicable):
0.1.22
Comment 1 Bill Peck 2016-01-22 09:38:04 EST
Merged
Comment 2 Dan Callaghan 2016-02-18 20:26:38 EST
Bill, was the precompiled module actually built against 7.0? I tried installing restraint-0.1.23-2.el7_2 on RHEL7.0 and the policy module failed to load:

  Installing : restraint-0.1.23-2.el7_2.x86_64                              1/1 
libsepol.permission_copy_callback: Module restraint depends on permission kill in class system, not satisfied (No such file or directory).
libsemanage.semanage_link_sandbox: Link packages failed (No such file or directory).
semodule:  Failed!

Not sure if that's too big of a deal or not. I didn't try on 7.1 yet but I imagine it's fine there.
Comment 3 Dan Callaghan 2016-04-20 20:42:31 EDT
https://gerrit.beaker-project.org/4593

Note You need to log in before you can comment on or make changes to this bug.