This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1298964 - packstack fails with "Nova_config[DEFAULT/auto_assign_floating_ip] is already declared in file"
packstack fails with "Nova_config[DEFAULT/auto_assign_floating_ip] is already...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
high Severity high
: ga
: 8.0 (Liberty)
Assigned To: Martin Magr
Yogev Rabl
: Automation, AutomationBlocker, TestOnly, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-15 09:32 EST by Jon Schlueter
Modified: 2016-04-15 09:46 EDT (History)
5 users (show)

See Also:
Fixed In Version: openstack-packstack-7.0.0-0.11.dev1692.g1b5e83b.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-15 09:46:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 268178 None None None 2016-01-15 10:04 EST
OpenStack gerrit 273091 None None None 2016-01-27 10:04 EST

  None (edit)
Description Jon Schlueter 2016-01-15 09:32:09 EST
Description of problem:

packstack fails with:

Error: Duplicate declaration: Nova_config[DEFAULT/auto_assign_floating_ip] is already declared in file /var/tmp/packstack/b4646346f5d94fbc8b73428a1c5b41f5/manifests/172.16.32.11_nova.pp:257


Version-Release number of selected component (if applicable):


How reproducible:

Always


Steps to Reproduce:
1. packstack install using attached config file
2.
3.

Actual results:

00:13:26.122 
172.16.32.11_nova.pp:                             [ ERROR ]
00:13:26.123 Applying Puppet manifests                         [ ERROR ]
00:13:26.124 
00:13:26.125 ERROR : Error appeared during Puppet run: 172.16.32.11_nova.pp
00:13:26.125 Error: Duplicate declaration: Nova_config[DEFAULT/auto_assign_floating_ip] is already declared in file /var/tmp/packstack/b4646346f5d94fbc8b73428a1c5b41f5/manifests/172.16.32.11_nova.pp:257; cannot redeclare at /var/tmp/packstack/b4646346f5d94fbc8b73428a1c5b41f5/modules/nova/manifests/network.pp:123 on node uk1pr-rhos-ci-20-rh-pud-pksk-controller.novalocal
00:13:26.128 You will find full trace in log /var/tmp/packstack/20160113-010457-xmpT35/manifests/172.16.32.11_nova.pp.log
00:13:26.129 

Expected results:

Install completes

Additional info:

<mmagr> I my guess is that in the past when installing nova-network the puppet modules did not set auto_assign_floating_ip config, so we did workaround for this: https://github.com/openstack/packstack/blob/stable/liberty/packstack/puppet/templates/nova_network.pp#L4

<mmagr> unfortunately current implementation in modules is doing so: https://github.com/redhat-openstack/openstack-puppet-modules/blob/stable/liberty/nova/manifests/network.pp#L122

<mmagr> jschlueter, so we have duplicate declaration
Comment 1 Jon Schlueter 2016-01-15 09:32 EST
Created attachment 1115170 [details]
packstack answer file
Comment 6 Yogev Rabl 2016-04-10 10:25:05 EDT
verified on 
openstack-packstack-2015.1-0.16.dev1589.g1d6372f.el7ost.noarch
Comment 8 errata-xmlrpc 2016-04-15 09:46:44 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0636.html

Note You need to log in before you can comment on or make changes to this bug.