Bug 1298976 - Error about lowering DC compatibility version appears when lowering cluster compatibility version
Error about lowering DC compatibility version appears when lowering cluster c...
Status: CLOSED NOTABUG
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.2
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-3.6.3
: ---
Assigned To: Eli Mesika
Petr Matyáš
infra
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-15 10:11 EST by Petr Matyáš
Modified: 2016-01-27 05:20 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-27 04:57:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
oourfali: ovirt‑3.6.z?
pmatyas: planning_ack?
pmatyas: devel_ack?
pmatyas: testing_ack?


Attachments (Terms of Use)
screenshot (35.77 KB, image/png)
2016-01-15 10:11 EST, Petr Matyáš
no flags Details

  None (edit)
Description Petr Matyáš 2016-01-15 10:11:53 EST
Created attachment 1115177 [details]
screenshot

Description of problem:
When lowering cluster compat version, error appears with 'Cannot decrease data center compatibility version' even though data center compat version is lower than what I'm trying to set in cluster.

Version-Release number of selected component (if applicable):
3.6.2-9

How reproducible:
always

Steps to Reproduce:
1. have DC with cluster on compat version 3.6
2. set DC compat version to 3.5 or 3.4
3. try to set cluster compat version to 3.5

Actual results:
error

Expected results:
exact/correct error with information what's wrong or compat version set to lower version

Additional info:
2016-01-15 16:06:32,359 WARN  [org.ovirt.engine.core.bll.UpdateVdsGroupCommand] (ajp-/127.0.0.1:8702-9) [88ebcf8] CanDoAction of action 'UpdateVdsGroup' failed for user admin@internal. Reasons: VAR__TYPE__CLUSTER,VAR__ACTION__UPDATE,ACTION_TYPE_FAILED_CANNOT_DECREASE_COMPATIBILITY_VERSION
Comment 1 Yaniv Kaul 2016-01-17 05:53:31 EST
Engine logs?
Comment 2 Eli Mesika 2016-01-17 10:01:11 EST
Not reproducible on master 
I guess that was fixed only on master and we have just to back-port the fix
Comment 3 Eli Mesika 2016-01-17 10:17:12 EST
Not reproducible on the 3.6 branch as well 
Petr, I had followed the exact scenario from bug description, can you please check again and tell me how to reproduce ?
Comment 4 Petr Matyáš 2016-01-18 07:26:42 EST
Sorry, I forgot to mention you have to have installed host in that cluster (not working with hosts either up or in maintenance)
Comment 5 Eli Mesika 2016-01-18 09:25:34 EST
As far as I see, the option to decrease a cluster version was issued by commit 1f9fa54a82474f5037200c29800f82419dc1f356
Looking at that commit I found the following comment in code 

// decreasing of compatibility version is only allowed when no hosts exists, and not beneath the DC version

So, it seems that this is working as designed
As far as I understand, if you want to be supported when host is in Maintenance, a RFE suits more that a simple bug since this is working IMO exactly as expected.

Oved, please decide how should we proceed with this BZ
Comment 6 Oved Ourfali 2016-01-18 12:40:41 EST
I agree. However, not sure it is a relevant use-case.
Moran?
Comment 7 Moran Goldboim 2016-01-27 04:57:13 EST
(In reply to Oved Ourfali from comment #6)
> I agree. However, not sure it is a relevant use-case.
> Moran?

Working by design, closing.

Note You need to log in before you can comment on or make changes to this bug.