Bug 1298993 - in search of minimal dependencies for building pmapi applications
in search of minimal dependencies for building pmapi applications
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pcp (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Nathan Scott
Miloš Prchlík
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-15 11:02 EST by Frank Ch. Eigler
Modified: 2016-11-04 00:23 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 00:23:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Ch. Eigler 2016-01-15 11:02:59 EST
Building a pcp client application out-of-tree naturally requires
the pcp-libs-devel package to provide headers/libraries.  However,
as of git pcp, this subrpm requires:

pcp
pcp-libs

(rhel 7.2 pcp is even worse dependency-wise, with the pcp-compat stuff,
but that is going away.)

The former of these dependencies is excessive, and brings in many
binaries, services, etc., that are irrelevant to the task of building
a pmapi program.  If there -is- something in the pcp subrpm that
is required, it should be moved into -libs or -libs-devel.
Comment 2 Lukas Berk 2016-06-09 09:40:51 EDT
Fixed upstream in commit: dc89e74e859f8b4c0a0ea0323614b716a569e3a6
RPM Packaging - new pcp-devel package with tools/docs

Leave pcp-libs-devel for just the libs and header files,
push devel pmdas and tools into pcp-devel and adjust the deps
accordingly
Comment 4 Miloš Prchlík 2016-08-20 12:26:17 EDT
Verified for build pcp-3.11.3-3.el7.
Comment 6 errata-xmlrpc 2016-11-04 00:23:03 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2344.html

Note You need to log in before you can comment on or make changes to this bug.