Bug 1299011 - blivet.errors.DeviceError: ('cannot replace active format', 'sdb2')
blivet.errors.DeviceError: ('cannot replace active format', 'sdb2')
Status: CLOSED DUPLICATE of bug 1172342
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:eef80d87780c336d1bc8da333f1...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-15 12:04 EST by Derek
Modified: 2016-01-15 12:32 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-15 12:32:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (1.33 MB, text/plain)
2016-01-15 12:04 EST, Derek
no flags Details
File: anaconda.log (34.56 KB, text/plain)
2016-01-15 12:04 EST, Derek
no flags Details
File: environ (614 bytes, text/plain)
2016-01-15 12:04 EST, Derek
no flags Details
File: journalctl (638.18 KB, text/plain)
2016-01-15 12:04 EST, Derek
no flags Details
File: lsblk_output (3.27 KB, text/plain)
2016-01-15 12:04 EST, Derek
no flags Details
File: nmcli_dev_list (2.56 KB, text/plain)
2016-01-15 12:04 EST, Derek
no flags Details
File: os_info (518 bytes, text/plain)
2016-01-15 12:04 EST, Derek
no flags Details
File: program.log (145.71 KB, text/plain)
2016-01-15 12:04 EST, Derek
no flags Details
File: storage.log (563.53 KB, text/plain)
2016-01-15 12:05 EST, Derek
no flags Details
File: ifcfg.log (7.59 KB, text/plain)
2016-01-15 12:05 EST, Derek
no flags Details

  None (edit)
Description Derek 2016-01-15 12:04:27 EST
Description of problem:
 I am trying to install Fedora on an external HDD from a liveUSB of Fedora. 
After choosing "Installation Destination", I selected my external HDD for installing Fedora 23. 
Next it tells me I need to reclaim space. I made a partition (NTFS) of about 100GiB for installing Fedora. 
When trying to reclaim space from a partition on my external HDD I continually receive the following error. 
This happens before I can even begin the installation process. 
The fedora iso is verified.

Version-Release number of selected component:
anaconda-core-23.19.10-1.fc23.x86_64

The following was filed automatically by anaconda:
anaconda 23.19.10-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python3.4/site-packages/blivet/devices/storage.py", line 695, in _setFormat
    raise errors.DeviceError("cannot replace active format", self.name)
  File "/usr/lib/python3.4/site-packages/blivet/devices/storage.py", line 740, in <lambda>
    lambda d,f: d._setFormat(f),
  File "/usr/lib/python3.4/site-packages/blivet/deviceaction.py", line 669, in apply
    self.device.format = None
  File "/usr/lib/python3.4/site-packages/blivet/devicetree.py", line 323, in registerAction
    action.apply()
  File "/usr/lib/python3.4/site-packages/blivet/devicetree.py", line 287, in recursiveRemove
    self.registerAction(ActionDestroyFormat(device))
  File "/usr/lib/python3.4/site-packages/blivet/blivet.py", line 607, in recursiveRemove
    self.devicetree.recursiveRemove(device)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/spokes/lib/resize.py", line 422, in _recursiveRemove
    self.storage.recursiveRemove(device)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/spokes/lib/resize.py", line 447, in _scheduleActions
    self._recursiveRemove(device)
blivet.errors.DeviceError: ('cannot replace active format', 'sdb2')

Additional info:
cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/syslinux/vmlinuz0 root=live:LABEL=LIVE ro rd.live.image quiet rhgb rd.live.check
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.2.3-300.fc23.x86_64
other involved packages: python3-blivet-1.12.8-1.fc23.noarch, anaconda-gui-23.19.10-1.fc23.x86_64
product:        Fedora
release:        Fedora release 23 (Twenty Three)
type:           anaconda
version:        23
Comment 1 Derek 2016-01-15 12:04:38 EST
Created attachment 1115194 [details]
File: anaconda-tb
Comment 2 Derek 2016-01-15 12:04:40 EST
Created attachment 1115195 [details]
File: anaconda.log
Comment 3 Derek 2016-01-15 12:04:42 EST
Created attachment 1115196 [details]
File: environ
Comment 4 Derek 2016-01-15 12:04:47 EST
Created attachment 1115197 [details]
File: journalctl
Comment 5 Derek 2016-01-15 12:04:49 EST
Created attachment 1115198 [details]
File: lsblk_output
Comment 6 Derek 2016-01-15 12:04:50 EST
Created attachment 1115199 [details]
File: nmcli_dev_list
Comment 7 Derek 2016-01-15 12:04:52 EST
Created attachment 1115200 [details]
File: os_info
Comment 8 Derek 2016-01-15 12:04:55 EST
Created attachment 1115201 [details]
File: program.log
Comment 9 Derek 2016-01-15 12:05:00 EST
Created attachment 1115202 [details]
File: storage.log
Comment 10 Derek 2016-01-15 12:05:02 EST
Created attachment 1115203 [details]
File: ifcfg.log
Comment 11 David Shea 2016-01-15 12:32:54 EST
You can't repartition the drive you booted from, since it's in use, running the live environment.

*** This bug has been marked as a duplicate of bug 1172342 ***

Note You need to log in before you can comment on or make changes to this bug.