Bug 129904 - oprofile plugin doesn't display a warning for incorrect kernel setting
Summary: oprofile plugin doesn't display a warning for incorrect kernel setting
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Developer Suite
Classification: Retired
Component: Profiling Plug-in   
(Show other bugs)
Version: 2.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Keith Seitz
QA Contact: eclipse-bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-08-13 21:41 UTC by Ben Konrath
Modified: 2015-01-31 17:59 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-01-31 17:59:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ben Konrath 2004-08-13 21:41:49 UTC
Description of problem:
If the user sets the kernel to vmlinuz instead of vmlinux, the plugin
doesn't detect this and issue a warning.

Additional info:
The plugin seems to be able to detect which kernel is running very
well.  The only reason I needed to change the kernel setting is
because I updated my kernel. Perhaps the plugin could autodetect the
kernel version everytime oprofiled is started. The current
configuration option could be grayed out unless explicitly set by the
user. A checkbox could control this. Just an idea though.

Comment 1 Jeremy Handcock 2004-10-23 18:20:54 UTC
This bug has been moved to
https://bugs.eclipse.org/bugs/show_bug.cgi?id=76884

This bug will remain open as a tracker.  All further comments
regarding this bug should be posted on bugs.eclipse.org.


Note You need to log in before you can comment on or make changes to this bug.