Bug 1299065 - Fix etcd hostname/ip address handling
Fix etcd hostname/ip address handling
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Andrew Butcher
Ma xiaoqiang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-15 16:07 EST by Eric Jones
Modified: 2016-07-03 20:47 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Installing OpenShift Enterprise 3.1
Last Closed: 2016-05-12 12:37:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Jones 2016-01-15 16:07:39 EST
Description of problem:
When the openshift_ip and openshift_hostname variables are defined in the /etc/ansible/hosts file, they appear to only be used for the installation and then not enforced anywhere else.

Version-Release number of selected component (if applicable):
Openshift 3.1 installer

How reproducible:
Uncerntain

Steps to Reproduce:
1. Setup /etc/ansible/hosts file to use a private interface, excluding the public interface 
2. Run the installer script

Actual results:
The installer uses the private interface but then the cluster fails to get started because it tries, and fails, to use the public interface.

Expected results:
The installer and Cluster use the private interface as setup in the ansible hosts file
Comment 2 Jason DeTiberus 2016-01-15 16:15:15 EST
We should wrap the etcd role(s) with openshift_etcd role(s) so that we can provide a consistent interface for configuring things like hostnames and ips for the etcd hosts.
Comment 9 Jason DeTiberus 2016-01-26 11:10:31 EST
Tracking this in the following trello card: https://trello.com/c/2tygIgBm
Comment 11 Jason DeTiberus 2016-03-15 22:58:21 EDT
Is this something that will be corrected with the certificate and delegate_to refactoring you've been working on?
Comment 12 Andrew Butcher 2016-03-17 11:50:56 EDT
(In reply to Jason DeTiberus from comment #11)
> Is this something that will be corrected with the certificate and
> delegate_to refactoring you've been working on?

No, the delegate_to isn't taking this into account currently.
Comment 19 errata-xmlrpc 2016-05-12 12:37:26 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1065

Note You need to log in before you can comment on or make changes to this bug.