Bug 1299072 - Multiple Issues with ClamAV Packages
Summary: Multiple Issues with ClamAV Packages
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: clamav
Version: epel7
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Robert Scheck
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-01-15 21:23 UTC by John Zimmerman
Modified: 2017-08-20 17:08 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-20 17:08:25 UTC
Type: Bug


Attachments (Terms of Use)

Description John Zimmerman 2016-01-15 21:23:57 UTC
Description of problem:

Installing ClamAV from EPEL appears to have multiple issues with generating a functional configuration.  Some of the issues include missing systemd configurations, wrong user listed in the config file when compared to what is created in the passwd file. etc..

A good summary of the steps required for a functional configuration after installing from the repository is covered on several blog posts one of which is here: http://linux-audit.com/install-clamav-on-centos-7-using-freshclam/


Version-Release number of selected component (if applicable):

clamav-server-0.98.7-1.el7.x86_64
clamav-0.98.7-1.el7.x86_64
clamav-filesystem-0.98.7-1.el7.noarch
clamav-server-systemd-0.98.7-1.el7.noarch
clamav-update-0.98.7-1.el7.x86_64
clamav-data-0.98.7-1.el7.noarch
clamav-scanner-0.98.7-1.el7.noarch
clamav-lib-0.98.7-1.el7.x86_64
clamav-scanner-systemd-0.98.7-1.el7.noarch


How reproducible:

Every time on install

Steps to Reproduce:
1. sudo yum install clamav-scanner clamav-scanner-systemd
2. sudo yum install clamav
3. sudo yum install clamav-update
4. sudo systemctl | grep clam

Actual results:

clamd.scan.service                                                                               not-found failed failed    clamd.scan.service

Expected results:

Opposite of failed.  As well as systemd configs for freshclam.

Additional info:

If this is the wrong channel to report an issue like this please let me know.  I'm happy to try to report through a more appropriate channel.

Thanks!

Comment 1 John Zimmerman 2016-02-12 20:48:56 UTC
Is it safe to assume that the packaging for Clam AV on CentOS 7 will not be fixed?

If so can it just be removed from the EPEL.  In it's current packaging state it probably shouldn't have been allowed to be included.

Comment 2 Robert Scheck 2016-02-12 21:42:55 UTC
I am not the ClamAV package maintainer, however I try to update the ClamAV
package if a newer version appears. In general ClamAV works for me while
using it with Amavisd-New. Nevertheless I agree with you, that the packaging
of ClamAV is not perfect. On the other hand this requires volunteers on both
packaging and user/testing side - where nobody seems to step up to support
this huge amount of effort in their free time.

I partially disagree with the URL you mentioned, e.g. "Missing systemd 
service file" is nonsense, there is a freshclam cronjob doing about the
same. I also disagree with "Change service files", this clearly feels
like the author did not understand how systemd instances work, so please
read "systemd.unit" before following these suggestions about moving and
changing systemd units.

Comment 3 Robert Scheck 2017-03-28 19:25:46 UTC
As per clamav-0.99.2-8.el7 the points mentioned should be sorted out,
additionally "systemctl enable clamd@scan.service" should to the same
like the article does by moving systemd unit files wildly around, the
already delivered configuration file is /etc/clamd.d/scan.conf.

Comment 4 Sergio Basto 2017-07-19 10:06:43 UTC
Hi,
TL,DR, clamav-0.99.2-8 is in stable can we close this bug ?

Comment 5 Sergio Basto 2017-08-20 17:08:25 UTC
please reopen it if it not fixed .


Note You need to log in before you can comment on or make changes to this bug.