Bug 1299077 - design of "Select Hosts" page in "Create Cluster" wizard is misleading
design of "Select Hosts" page in "Create Cluster" wizard is misleading
Status: CLOSED ERRATA
Product: Red Hat Storage Console
Classification: Red Hat
Component: UI (Show other bugs)
2
Unspecified Unspecified
unspecified Severity medium
: ---
: 2
Assigned To: sankarshan
sds-qe-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-15 16:50 EST by Martin Bukatovic
Modified: 2016-08-23 15:46 EDT (History)
6 users (show)

See Also:
Fixed In Version: rhscon-ui-0.0.23-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-23 15:46:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
img 01 (86.22 KB, image/png)
2016-01-15 16:52 EST, Martin Bukatovic
no flags Details
img 02 (80.17 KB, image/png)
2016-01-15 16:53 EST, Martin Bukatovic
no flags Details
img 03 (87.87 KB, image/png)
2016-01-15 16:53 EST, Martin Bukatovic
no flags Details
img 04 (92.46 KB, image/png)
2016-01-15 16:54 EST, Martin Bukatovic
no flags Details
img 05 (91.94 KB, image/png)
2016-01-15 16:54 EST, Martin Bukatovic
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1754 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 15:09:06 EDT

  None (edit)
Description Martin Bukatovic 2016-01-15 16:50:17 EST
Description of problem
======================

The design of "Select Hosts" page in "Create Cluster" wizard is misleading
and unfriendly for first time user of Sky Ring web interface.

Version-Release number of selected component
============================================

# rpm -qa | grep rhscon
rhscon-core-0.0.6-0.1.alpha1.el7.x86_64
rhscon-ui-0.0.6-0.1.alpha1.el7.noarch
rhscon-ceph-0.0.4-0.1.alpha1.el7.x86_64

Steps to Reproduce
==================

1. Install skyring on server and prepare few hosts for cluster setup
2. Accept all nodes
3. Select "Clusters" from left pane menu, start "Create Cluster" wizard
4. Stop on 2nd page of the wizard called "Select Hosts"

Actual results
===============

On this page, user can see list of hosts with some icons and additional
information (see img 01 which shows the default state of this page).

Icon for Ceph OSD role (OSD):

 - it's not visible at all by default (or in other words, not-selected OSD icon
   is invisible), one has to click in the empty space (which is quite unlikely)
   or click "Select All" (img 04)
 - when clicked, it's visible as checked box symbol (img 03)
 - doesn't have any title text with an explanation

Icon for the accepted state:

 - looks like little green circle with check symbol (this is very similar to
   selected OSD role)
 - has no title text or any other explanation, so it's completely puzzling
   for someone who accepted all hosts before starting "Create Cluster" wizard

Icon for Ceph Monitor role (MON):

 - looks like LCD computer screen or iMac computer (it has nothing to do
   with Ceph MON daemon, with the exception of the name, which I guess
   is not a good/clear enough here)
 - the very same icon is used for "Hosts" tab in left menubar, where it
   represents a machine (img 02)
 - the very same icon is used for "Discovered Hosts" popup windows in the
   top black panel, where it represents a machine (img 02)
 - is placed in the end of host entry (so it's on the other side compared to
   icon of Ceph OSD role)
 - it's displayed in barelly visible grey color by default (this is supposed
   to mean that the role is not applied, but this is apparent only when you
   compare this state with iconn for selected MON role) (see img 05)
 - the only suggestion what this icon does is it's title text, which states:
   "Use this host as Ceph monitor"
 - it can be enabled only by clicking on it

Now I try to highlight most striking issues:

Most people would assume that monitor icon has no special meaning  and that it
just signifies that the entry represents a single host (it is used
to represent a machine in 2 other places after all).

Icon for accepted state and selected OSD role looks similar, but what
information would we like to convey by this choice? This just makes missing
MON role more likely.

Why do we put icons for OSD and MON role on the *opposite sides* of a host
entry?  What does that mean? Again, this just makes missing MON role more
likely.

The only hint that one can assign MON to host(s) on this page
is present in image title text (so that one has to hover cursor over it) of an
icon which will be most likely completely missed.

The only way to assign MON role to host is to click on the icon which is
most likely to be completely missed. 

Expected results
================

I'm not a designer, but here are some of my suggestions:

 * change icon for OSD role, something as self explanatory as icon which reads
   "OSD" would be much better
 * change icon for MON role, something as self explanatory as icon which reads
   "MON" would be much better
 * make icon for OSD and MON more similar (so that its clear that both
   represent similar concept - assigned ceph role)
 * make icon for unselected OSD visible - grey color similar to current grey
   unselected MON iMac icon would be enough
 * add title texts with quick explanation for all host icons 
   (OSD, MON, fingerprint and accepted-state)
 * move MON icon next to OSD one
 * add some quick text which would explain what is going on in this step,
   which would mention both OSD and MON roles
Comment 1 Martin Bukatovic 2016-01-15 16:52 EST
Created attachment 1115294 [details]
img 01
Comment 2 Martin Bukatovic 2016-01-15 16:53 EST
Created attachment 1115295 [details]
img 02
Comment 3 Martin Bukatovic 2016-01-15 16:53 EST
Created attachment 1115296 [details]
img 03
Comment 4 Martin Bukatovic 2016-01-15 16:54 EST
Created attachment 1115297 [details]
img 04
Comment 5 Martin Bukatovic 2016-01-15 16:54 EST
Created attachment 1115298 [details]
img 05
Comment 7 Daniel Horák 2016-01-20 08:49:43 EST
There should be also opposite button for *Select All*, something like *Unselect All / Reset*.
Comment 11 Martin Kudlej 2016-07-22 02:39:16 EDT
Tested with 
ceph-ansible-1.0.5-27.el7scon.noarch
ceph-installer-1.0.14-1.el7scon.noarch
rhscon-ceph-0.0.33-1.el7scon.x86_64
rhscon-core-0.0.34-1.el7scon.x86_64
rhscon-core-selinux-0.0.34-1.el7scon.noarch
rhscon-ui-0.0.48-1.el7scon.noarch
and it is redesigned and it is more usable than design at screenshots. 

Missing feature from comment #7.
Comment 12 Nishanth Thomas 2016-07-22 08:52:03 EDT
As per the discussion, moving to ON_QA. Please raise a RFE if you want to have this fetaure added to USM
Comment 13 Martin Kudlej 2016-07-26 04:51:32 EDT
I filed bug 1360204 as RFE.
Comment 15 errata-xmlrpc 2016-08-23 15:46:02 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754

Note You need to log in before you can comment on or make changes to this bug.