Bug 1299117 - SELinux prevents cron from running after reboot
SELinux prevents cron from running after reboot
Status: CLOSED DUPLICATE of bug 1298192
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
23
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-15 21:20 EST by André Martins
Modified: 2016-01-16 19:29 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-16 19:29:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description André Martins 2016-01-15 21:20:01 EST
Description of problem:
SELinux prevents cron from running after reboot


Version-Release number of selected component (if applicable):
selinux-policy-3.13.1-158.fc23.noarch

How reproducible:
Always

Steps to Reproduce:
1. Write a file with the following contents "@reboot echo "disable" > /sys/firmware/acpi/interrupts/gpe06" under "-rw-------. 1 root root 61 Sep 13 15:21 /var/spool/cron/root"
2. Reboot the machine
3. do # tail /var/log/cron

Actual results:
Jan 15 22:49:19 aanm-MBP crond[1591]: (CRON) INFO (RANDOM_DELAY will be scaled with factor 38% if used.)
Jan 15 22:49:19 aanm-MBP crond[1591]: (root) Unauthorized SELinux context=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 file_context=unconfined_u:object_r:user_cron_spool_t:s0 (/var/spool/cron/root)
Jan 15 22:49:19 aanm-MBP crond[1591]: (root) FAILED (loading cron table)
Jan 15 22:49:19 aanm-MBP crond[1591]: (CRON) INFO (running with inotify support)


Expected results:
Non failures
Comment 1 Volker Sobek 2016-01-16 12:18:23 EST
Might be the same as https://bugzilla.redhat.com/show_bug.cgi?id=1298192
Comment 2 André Martins 2016-01-16 19:29:52 EST

*** This bug has been marked as a duplicate of bug 1298192 ***

Note You need to log in before you can comment on or make changes to this bug.