Bug 1299142 - python-pyspf: Provide a Python 3 subpackage
python-pyspf: Provide a Python 3 subpackage
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-pyspf (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Paul Wouters
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: PYTHON3 PY3PATCH-PUSH
  Show dependency treegraph
 
Reported: 2016-01-16 10:13 EST by Petr Viktorin
Modified: 2016-12-04 00:25 EST (History)
4 users (show)

See Also:
Fixed In Version: python-pyspf-2.0.12-1.fc26 python-pyspf-2.0.12-1.fc25 python-pyspf-2.0.12-1.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-03 21:26:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
New version including Python 3 subpackage (6.23 KB, patch)
2016-09-07 11:09 EDT, Jan Beran
no flags Details | Diff
Adjusted spec file (6.16 KB, patch)
2016-09-08 08:34 EDT, Jan Beran
no flags Details | Diff
Updated spec file (6.15 KB, patch)
2016-09-08 09:28 EDT, Jan Beran
no flags Details | Diff
Updated spec file (6.15 KB, patch)
2016-10-06 03:24 EDT, Jan Beran
no flags Details | Diff
Updated spec file (6.31 KB, patch)
2016-10-08 08:27 EDT, Jan Beran
no flags Details | Diff
Updated spec file (6.28 KB, patch)
2016-10-11 11:48 EDT, Jan Beran
no flags Details | Diff

  None (edit)
Description Petr Viktorin 2016-01-16 10:13:14 EST
Upstream, this software supports Python 3. Please provide a Python 3
package for Fedora.


According to the Python packaging guidelines [0], software must be
packaged for Python 3 if upstream supports it.
The guidelines give detailed information on how to do this, and even
provide an example spec file [1].

The current best practice is to provide subpackages for the two Python
versions (called "Common SRPM" in the guidelines). Alternatively, if
nothing depends on your Python2 package, you can just switch to Python 3
entirely.

It's fine to do this in Rawhide only.


If anything is unclear, or if you need any kind of assistance with the
porting, you can ask on IRC (#fedora-python on Freenode), or reply here.
We'll be happy to help!


[0] https://fedoraproject.org/wiki/Packaging:Python
[1] https://fedoraproject.org/wiki/Packaging:Python#Example_common_spec_file
Comment 1 Charalampos Stratakis 2016-02-15 10:50:39 EST
Ping?

No response as of yet from maintainer.

Also latest upstream version: 2.0.12
Comment 2 Jan Kurik 2016-02-24 09:17:41 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 3 Dominika Krejčí 2016-05-04 11:15:10 EDT
Hello Paul,

Do you need any help adding Python 3 support to the RPM?

If you need more instructions, a [guide] for porting Python-based RPMs is available.

[guide] http://python-rpm-porting.readthedocs.org/en/latest/index.html
Comment 4 Jan Beran 2016-09-07 11:09 EDT
Created attachment 1198762 [details]
New version including Python 3 subpackage
Comment 5 Dominika Krejčí 2016-09-08 03:30:32 EDT
(In reply to Jan Beran from comment #4)
> Created attachment 1198762 [details]
> New version including Python 3 subpackage

Hi Jan, please, do not define `%global summary` macro on the second line, it is redundant, because there is already `Summary:` tag. ;)

Koji scratch buid: http://koji.fedoraproject.org/koji/taskinfo?taskID=15539340
Comment 6 Jan Beran 2016-09-08 08:34 EDT
Created attachment 1199059 [details]
Adjusted spec file

Hi Dominika,

thank you for the review. I attach the spec file where the inappropriate name is fixed.
Comment 7 Dominika Krejčí 2016-09-08 08:54:18 EDT
Delete second line in the specfile. Do not specify the macro at all (no %global sum/summary). It will be automatically defined by the `Summary: Python module...` tag. Than you can use %{summary} in the rest of the spec, as you did in the first case.
Take a look at the example spefile there: http://python-rpm-porting.readthedocs.io/en/latest/application-modules.html#ported-rpm-spec-file
Comment 8 Jan Beran 2016-09-08 09:28 EDT
Created attachment 1199100 [details]
Updated spec file

Hi Dominika, thank you for the hint, I have fixed the spec file. (I am really stupid, it is logical).
Comment 9 Dominika Krejčí 2016-09-08 09:46:24 EDT
Hi Jan,
same issue with summary there. Definition of %{sum} macro is redundant.
Comment 10 Jan Beran 2016-09-08 10:05:03 EDT
Hi Dominika, you probably refer to another bugzillas (I am going to fix it there), not this one.
Comment 11 Dominika Krejčí 2016-09-08 10:10:32 EDT
(In reply to Jan Beran from comment #10)
> Hi Dominika, you probably refer to another bugzillas (I am going to fix it
> there), not this one.

Of course, I had more bugs opened, sorry. It supposed to be #1333816.
Comment 12 Dominika Krejčí 2016-10-05 10:26:37 EDT
Hi Jan, there are two more comments:

* Please, do not add "- Python X version" to %{summary} in subpackages, it is too long. Keep it just in the description is fine.

* Scripts type99 and spfquery probably should have executable rights.
Comment 13 Jan Beran 2016-10-06 03:24 EDT
Created attachment 1207833 [details]
Updated spec file

Hi Dominika,

thanks for your review. I include the updated spec file that fixes your findings.
Comment 14 Dominika Krejčí 2016-10-07 03:38:31 EDT
My mistake. The problem was not with type99 and spfquery (it was ok in the previous version of the spec), but with spf.py:

`E: non-executable-script /usr/lib/python3.5/site-packages/spf.py 644 /usr/bin/python`

I can be solved by removing the shebang in this file.
Comment 15 Jan Beran 2016-10-08 08:27 EDT
Created attachment 1208332 [details]
Updated spec file

Hi Dominika,

thank you for the feedback. I have prepared fixes in the attachment. May I ask you to review again?
Comment 16 Dominika Krejčí 2016-10-11 03:07:03 EDT
Hallo Jan,
I hope, this will be the last thing: Please, keep the License as it was in the original specfile (just Python). Python Software Foundation License is not recognized by rpmlint and `Python` is acceptable shortcut for it. :)

`python-pyspf.src: W: invalid-license Python Software Foundation License`
Comment 17 Jan Beran 2016-10-11 11:48 EDT
Created attachment 1209198 [details]
Updated spec file

Hi Dominika,

my rpmlint did not report any error. However, I have updated the spec file by the short name license.

Thanks for your reviews and support.
Comment 18 Dominika Krejčí 2016-10-12 10:58:03 EDT
Hi Jan, the spec looks good to me. If maintainer has nothing against, we can push this change after a week.

Koji scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=16060652
Comment 19 Charalampos Stratakis 2016-11-16 12:04:52 EST
Modified a bit the SPEC file to fix some issues related to the ipaddress module requirement and the patch that was included in the package sources.

Commit is pushed and the package has been built for rawhide. If it is required to build it as well for F25 please reopen the bug.
Comment 20 Fedora Update System 2016-11-30 08:41:23 EST
python-pyspf-2.0.12-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-ae93fe8b26
Comment 21 Fedora Update System 2016-11-30 08:46:06 EST
python-pyspf-2.0.12-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-11e8f660a4
Comment 22 Fedora Update System 2016-12-02 23:33:37 EST
python-pyspf-2.0.12-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-ae93fe8b26
Comment 23 Fedora Update System 2016-12-03 00:40:20 EST
python-pyspf-2.0.12-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-11e8f660a4
Comment 24 Fedora Update System 2016-12-03 21:26:28 EST
python-pyspf-2.0.12-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.
Comment 25 Fedora Update System 2016-12-04 00:25:18 EST
python-pyspf-2.0.12-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.