Bug 1299167 - Attempt to provide back trace for ksplashqml found packaging problems
Attempt to provide back trace for ksplashqml found packaging problems
Status: CLOSED DUPLICATE of bug 1318541
Product: Fedora
Classification: Fedora
Component: kde-workspace (Show other bugs)
24
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-16 16:24 EST by George R. Goffe
Modified: 2016-03-21 08:40 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-21 08:40:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George R. Goffe 2016-01-16 16:24:20 EST
Description of problem:

I was attempting to provide a back trace for a core file that ksplashqml caused. gdb asked for more symbols and recommended debug-info. Subsequent install of debug info revealed packaging problems.

Version-Release number of selected component (if applicable):



How reproducible:
 always

Steps to Reproduce:
1.unknown
2.
3.

Actual results:


Expected results:


Additional info:
gdb ksplashqml core.3029
GNU gdb (GDB) Fedora 7.10.50.20160106-42.fc24
Copyright (C) 2016 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from ksplashqml...Reading symbols from /usr/lib/debug/usr/bin/ksplashqml.debug...done.
done.
[New LWP 3029]
[New LWP 3032]

warning: the debug information found in "/usr/lib/debug//usr/lib64/libQt5Network.so.5.6.0.debug" does not match "/usr/lib64/libQt5Network.so.5" (CRC mismatch).


warning: the debug information found in "/usr/lib/debug//usr/lib64/libQt5DBus.so.5.6.0.debug" does not match "/usr/lib64/libQt5DBus.so.5" (CRC mismatch).


warning: the debug information found in "/usr/lib/debug//usr/lib64/libQt5Gui.so.5.6.0.debug" does not match "/usr/lib64/libQt5Gui.so.5" (CRC mismatch).


warning: the debug information found in "/usr/lib/debug//usr/lib64/libQt5Core.so.5.6.0.debug" does not match "/usr/lib64/libQt5Core.so.5" (CRC mismatch).


warning: the debug information found in "/usr/lib/debug//usr/lib64/libQt5Widgets.so.5.6.0.debug" does not match "/usr/lib64/libQt5Widgets.so.5" (CRC mismatch).

[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib64/libthread_db.so.1".

warning: the debug information found in "/usr/lib/debug//usr/lib64/libssl.so.1.0.2e.debug" does not match "/usr/lib64/libssl.so.10" (CRC mismatch).


warning: the debug information found in "/usr/lib/debug//usr/lib64/libcrypto.so.1.0.2e.debug" does not match "/usr/lib64/libcrypto.so.10" (CRC mismatch).


warning: the debug information found in "/usr/lib/debug//usr/lib64/libQt5Xml.so.5.6.0.debug" does not match "/usr/lib64/libQt5Xml.so.5" (CRC mismatch).


warning: the debug information found in "/usr/lib/debug//usr/lib64/libQt5Concurrent.so.5.6.0.debug" does not match "/usr/lib64/libQt5Concurrent.so.5" (CRC mismatch).


warning: the debug information found in "/usr/lib/debug//usr/lib64/libselinux.so.1.debug" does not match "/usr/lib64/libselinux.so.1" (CRC mismatch).


warning: the debug information found in "/usr/lib/debug//usr/lib64/qt5/plugins/platforms/libqxcb.so.debug" does not match "/usr/lib64/qt5/plugins/platforms/libqxcb.so" (CRC mismatch).


warning: the debug information found in "/usr/lib/debug//usr/lib64/libQt5XcbQpa.so.5.6.0.debug" does not match "/usr/lib64/libQt5XcbQpa.so.5" (CRC mismatch).


warning: the debug information found in "/usr/lib/debug//usr/lib64/qt5/plugins/xcbglintegrations/libqxcb-glx-integration.so.debug" does not match "/usr/lib64/qt5/plugins/xcbglintegrations/libqxcb-glx-integration.so" (CRC mismatch).


warning: the debug information found in "/usr/lib/debug//usr/lib64/qt5/plugins/platforminputcontexts/libcomposeplatforminputcontextplugin.so.debug" does not match "/usr/lib64/qt5/plugins/platforminputcontexts/libcomposeplatforminputcontextplugin.so" (CRC mismatch).


warning: the debug information found in "/usr/lib/debug//usr/lib64/qt5/plugins/imageformats/libqgif.so.debug" does not match "/usr/lib64/qt5/plugins/imageformats/libqgif.so" (CRC mismatch).


warning: the debug information found in "/usr/lib/debug//usr/lib64/qt5/plugins/imageformats/libqico.so.debug" does not match "/usr/lib64/qt5/plugins/imageformats/libqico.so" (CRC mismatch).


warning: the debug information found in "/usr/lib/debug//usr/lib64/qt5/plugins/imageformats/libqjpeg.so.debug" does not match "/usr/lib64/qt5/plugins/imageformats/libqjpeg.so" (CRC mismatch).

Core was generated by `ksplashqml Breeze --pid'.
Program terminated with signal SIGFPE, Arithmetic exception.
#0  0x00007fa05d64ef19 in pthread_barrier_destroy (barrier=barrier@entry=0x562ac2caf220) at pthread_barrier_destroy.c:39
39        unsigned int max_in_before_reset = BARRIER_IN_THRESHOLD
[Current thread is 1 (Thread 0x7fa051df68c0 (LWP 3029))]
Missing separate debuginfos, use: dnf debuginfo-install bzip2-libs-1.0.6-19.fc24.x86_64 libgcc-5.3.1-3.fc24.x86_64 libselinux-2.4-6.fc24.x86_64 libstdc++-5.3.1-3.fc24.x86_64 openssl-libs-1.0.2e-3.fc24.x86_64 qt5-qtbase-5.6.0-0.19.beta.fc24.x86_64 qt5-qtbase-gui-5.6.0-0.19.beta.fc24.x86_64
(gdb) 
(gdb) where
#0  0x00007fa05d64ef19 in pthread_barrier_destroy (barrier=barrier@entry=0x562ac2caf220) at pthread_barrier_destroy.c:39
#1  0x00007fa046f8717f in lp_rast_destroy (barrier=0x562ac2caf220) at ../../../../src/gallium/auxiliary/os/os_thread.h:155
#2  0x00007fa046f8717f in lp_rast_destroy (rast=0x562ac2cadb00) at lp_rast.c:970
#3  0x00007fa046f92ce1 in llvmpipe_destroy_screen (_screen=0x562ac2cad9f0) at lp_screen.c:525
#4  0x00007fa046bda8df in dri_destroy_screen_helper (screen=screen@entry=0x562ac2c85250) at dri_screen.c:380
#5  0x00007fa046bda985 in dri_destroy_screen (sPriv=0x562ac2c851b0) at dri_screen.c:391
#6  0x00007fa046bd8cdf in driDestroyScreen (psp=0x562ac2c851b0) at dri_util.c:228
#7  0x00007fa05d3ea4c2 in driswDestroyScreen (base=0x562ac2c64710) at drisw_glx.c:587
#8  0x00007fa05d3c64a6 in FreeScreenConfigs (priv=0x562ac2c61950, priv=0x562ac2c61950) at glxext.c:217
#9  0x00007fa05d3c6529 in glx_display_free (priv=priv@entry=0x562ac2c61950) at glxext.c:240
#10 0x00007fa05d3c667e in __glXCloseDisplay (dpy=0x562ac2c31fa0, codes=<optimized out>) at glxext.c:288
#11 0x00007fa05761ddb2 in XCloseDisplay (dpy=0x562ac2c31fa0) at ClDisplay.c:65
#12 0x00007fa04a959f0f in QXcbConnection::~QXcbConnection() () at /usr/lib64/libQt5XcbQpa.so.5
#13 0x00007fa04a95a289 in QXcbConnection::~QXcbConnection() () at /usr/lib64/libQt5XcbQpa.so.5
#14 0x00007fa04a95ba66 in QXcbIntegration::~QXcbIntegration() () at /usr/lib64/libQt5XcbQpa.so.5
#15 0x00007fa04a95bb69 in QXcbIntegration::~QXcbIntegration() () at /usr/lib64/libQt5XcbQpa.so.5
#16 0x00007fa06091c187 in QGuiApplicationPrivate::~QGuiApplicationPrivate() () at /usr/lib64/libQt5Gui.so.5
#17 0x00007fa06091c329 in QGuiApplicationPrivate::~QGuiApplicationPrivate() () at /usr/lib64/libQt5Gui.so.5
#18 0x00007fa06060c84c in QObject::~QObject() () at /usr/lib64/libQt5Core.so.5
#19 0x00007fa0605da3b2 in QCoreApplication::~QCoreApplication() () at /usr/lib64/libQt5Core.so.5
#20 0x0000562ac2275aeb in main(int, char**) (argc=3, argv=<optimized out>) at /usr/src/debug/plasma-workspace-5.5.3/ksplash/ksplashqml/main.cpp:89



fc24-rawhide--bash 4.3 ~# dnf debuginfo-install bzip2-libs-1.0.6-19.fc24.x86_64 libgcc-5.3.1-3.fc24.x86_64 libselinux-2.4-6.fc24.x86_64 libstdc++-5.3.1-3.fc24.x86_64 openssl-libs-1.0.2e-3.fc24.x86_64 qt5-qtbase-5.6.0-0.19.beta.fc24.x86_64 qt5-qtbase-gui-5.6.0-0.19.beta.fc24.x86_64
enabling rawhide-debuginfo repository


Failed to synchronize cache for repo 'kde-testing' from 'http://apt.kde-redhat.org/apt/kde-redhat/fedora/mirrors-testing': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried, disabling.
Failed to synchronize cache for repo 'kde' from 'http://apt.kde-redhat.org/apt/kde-redhat/fedora/mirrors-stable': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried, disabling.
Last metadata expiration check performed 0:00:05 ago on Sat Jan 16 14:14:11 2016.
Package glibc-debuginfo-2.22.90-29.fc24.x86_64 is already installed, skipping.
Package nss-softokn-debuginfo-3.21.0-5.fc24.x86_64 is already installed, skipping.
Package libselinux-debuginfo-2.4-7.fc24.x86_64 is already installed, skipping.
Package pcre-debuginfo-8.38-6.fc24.x86_64 is already installed, skipping.
Package openssl-debuginfo-1:1.0.2e-5.fc24.x86_64 is already installed, skipping.
Package zlib-debuginfo-1.2.8-9.fc24.x86_64 is already installed, skipping.
Package e2fsprogs-debuginfo-1.42.13-3.fc23.x86_64 is already installed, skipping.
Package krb5-debuginfo-1.14-13.fc24.x86_64 is already installed, skipping.
Package keyutils-debuginfo-1.5.9-7.fc24.x86_64 is already installed, skipping.
Package libverto-debuginfo-0.2.6-5.fc23.x86_64 is already installed, skipping.
Package qt5-qtbase-debuginfo-5.6.0-0.20.beta.fc24.x86_64 is already installed, skipping.
Package glib2-debuginfo-2.47.4-1.fc24.x86_64 is already installed, skipping.
Package libffi-debuginfo-3.1-8.fc23.x86_64 is already installed, skipping.
Package dbus-debuginfo-1:1.11.0-1.fc24.x86_64 is already installed, skipping.
Package systemd-debuginfo-228-7.gite35a787.fc24.x86_64 is already installed, skipping.
Package libgpg-error-debuginfo-1.21-1.fc24.x86_64 is already installed, skipping.
Package pam-debuginfo-1.2.1-3.fc24.x86_64 is already installed, skipping.
Package libdb-debuginfo-5.3.28-13.fc23.x86_64 is already installed, skipping.
Package audit-debuginfo-2.5-1.fc24.x86_64 is already installed, skipping.
Package cracklib-debuginfo-2.9.6-1.fc24.x86_64 is already installed, skipping.
Package xz-debuginfo-5.2.2-1.fc24.x86_64 is already installed, skipping.
Package libgcrypt-debuginfo-1.6.4-1.fc24.x86_64 is already installed, skipping.
Package acl-debuginfo-2.2.52-10.fc24.x86_64 is already installed, skipping.
Package attr-debuginfo-2.4.47-15.fc24.x86_64 is already installed, skipping.
Package libcap-debuginfo-2.24-8.fc23.x86_64 is already installed, skipping.
Package libidn-debuginfo-1.32-1.fc24.x86_64 is already installed, skipping.
Package libseccomp-debuginfo-2.2.3-0.fc23.x86_64 is already installed, skipping.
Package lz4-debuginfo-r131-1.fc23.x86_64 is already installed, skipping.
Package sqlite-debuginfo-3.10.0-1.fc24.x86_64 is already installed, skipping.
Package ncurses-debuginfo-6.0-1.20150810.fc24.x86_64 is already installed, skipping.
Package readline-debuginfo-6.3-7.fc24.x86_64 is already installed, skipping.
Package icu-debuginfo-56.1-1.fc24.x86_64 is already installed, skipping.
Package libproxy-debuginfo-0.4.11-12.fc23.x86_64 is already installed, skipping.
Package libmodman-debuginfo-2.0.1-11.fc23.x86_64 is already installed, skipping.
Package libX11-debuginfo-1.6.3-2.fc23.x86_64 is already installed, skipping.
Package libxcb-debuginfo-1.11.1-1.fc24.x86_64 is already installed, skipping.
Package libXau-debuginfo-1.0.8-5.fc23.x86_64 is already installed, skipping.
Package freetype-debuginfo-2.6.2-1.fc24.x86_64 is already installed, skipping.
Package libpng-debuginfo-2:1.6.20-2.fc24.x86_64 is already installed, skipping.
Package fontconfig-debuginfo-2.11.94-5.fc24.x86_64 is already installed, skipping.
Package expat-debuginfo-2.1.0-12.fc23.x86_64 is already installed, skipping.
Package libXext-debuginfo-1.3.3-3.fc23.x86_64 is already installed, skipping.
Package mesa-debuginfo-11.2.0-0.devel.5.5e3edd4.fc24.x86_64 is already installed, skipping.
Package libXfixes-debuginfo-5.0.1-5.fc23.x86_64 is already installed, skipping.
Package libXdamage-debuginfo-1.1.4-7.fc23.x86_64 is already installed, skipping.
Package libdrm-debuginfo-2.4.66-1.fc24.x86_64 is already installed, skipping.
Package libpciaccess-debuginfo-0.13.4-2.fc23.x86_64 is already installed, skipping.
Package libXxf86vm-debuginfo-1.1.4-2.fc23.x86_64 is already installed, skipping.
Package libxshmfence-debuginfo-1.2-2.fc23.x86_64 is already installed, skipping.
Package libjpeg-turbo-debuginfo-1.4.2-2.fc24.x86_64 is already installed, skipping.
Package libSM-debuginfo-1.2.2-3.fc23.x86_64 is already installed, skipping.
Package libICE-debuginfo-1.0.9-3.fc23.x86_64 is already installed, skipping.
Package util-linux-debuginfo-2.27.1-3.fc24.x86_64 is already installed, skipping.
Package libXrender-debuginfo-0.9.9-2.fc23.x86_64 is already installed, skipping.
Package libXi-debuginfo-1.7.6-1.fc24.x86_64 is already installed, skipping.
Package libxkbcommon-debuginfo-0.5.0-3.fc24.x86_64 is already installed, skipping.
Package wayland-debuginfo-1.9.0-1.fc24.x86_64 is already installed, skipping.
Package cups-debuginfo-1:2.1.2-1.fc24.x86_64 is already installed, skipping.
Package gnutls-debuginfo-3.4.8-1.fc24.x86_64 is already installed, skipping.
Package gmp-debuginfo-1:6.1.0-1.fc24.x86_64 is already installed, skipping.
Package nettle-debuginfo-3.1.1-6.fc24.x86_64 is already installed, skipping.
Package p11-kit-debuginfo-0.23.2-1.fc24.x86_64 is already installed, skipping.
Package libtasn1-debuginfo-4.7-1.fc24.x86_64 is already installed, skipping.
Package avahi-debuginfo-0.6.32-0.5.rc.fc24.x86_64 is already installed, skipping.
Package harfbuzz-debuginfo-1.1.3-1.fc24.x86_64 is already installed, skipping.
Package graphite2-debuginfo-1.2.4-5.fc23.x86_64 is already installed, skipping.
Package libinput-debuginfo-1.1.4-2.fc24.x86_64 is already installed, skipping.
Package libevdev-debuginfo-1.4.5-2.fc24.x86_64 is already installed, skipping.
Package mtdev-debuginfo-1.1.5-5.fc23.x86_64 is already installed, skipping.
Package xcb-util-keysyms-debuginfo-0.4.0-2.fc23.x86_64 is already installed, skipping.
Package xcb-util-image-debuginfo-0.4.0-4.fc24.x86_64 is already installed, skipping.
Package xcb-util-debuginfo-0.4.0-4.fc24.x86_64 is already installed, skipping.
Package xcb-util-wm-debuginfo-0.4.1-7.fc24.x86_64 is already installed, skipping.
Package xcb-util-renderutil-debuginfo-0.3.9-5.fc24.x86_64 is already installed, skipping.
Dependencies resolved.
Nothing to do.
Complete!
Comment 1 Jan Kurik 2016-02-24 10:33:16 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 2 Rex Dieter 2016-03-21 08:40:19 EDT
I'm not sure the problems are you mention, but the backtrace is a dup of bug #1318541

*** This bug has been marked as a duplicate of bug 1318541 ***

Note You need to log in before you can comment on or make changes to this bug.