Bug 1299174 - upgrading 21 to 22 system upgrade plugin fails to load
upgrading 21 to 22 system upgrade plugin fails to load
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dnf-plugin-system-upgrade (Show other bugs)
22
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-16 20:00 EST by Paul Rutledge
Modified: 2016-01-20 08:50 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-20 08:50:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dnf log (47.57 KB, text/plain)
2016-01-16 20:00 EST, Paul Rutledge
no flags Details

  None (edit)
Description Paul Rutledge 2016-01-16 20:00:34 EST
Created attachment 1115530 [details]
dnf log

Description of problem:
dnf fails to load upgrade plugin

Version-Release number of selected component (if applicable):
Package dnf-plugin-system-upgrade-0.5.0-1.fc21.noarch is already installed, skipping.

How reproducible:
every time attempted to upgrade

Steps to Reproduce:
1.sudo dnf install dnf-plugin-system-upgrade
2.Package dnf-plugin-system-upgrade-0.5.0-1.fc21.noarch is already installed, skipping.
Dependencies resolved.
Nothing to do.
Complete!

3.sudo dnf system-upgrade download --releasever=22
Failed loading plugin: system_upgrade
No such command: system-upgrade. Please use /bin/dnf --help
It could be a DNF plugin command.

sudo dnf system-upgrade reboot
Failed loading plugin: system_upgrade
No such command: system-upgrade. Please use /bin/dnf --help
It could be a DNF plugin command.


Actual results:


Expected results:


Additional info:
last dnf log attached
Comment 1 Will Woods 2016-01-18 12:24:52 EST
Here's the traceback, from the log:

  Jan 16 21:52:18 ERROR Failed loading plugin: system_upgrade
  Jan 16 21:52:18 SUBDEBUG 
  Traceback (most recent call last):
    File "/usr/lib/python2.7/site-packages/dnf/plugin.py", line 124, in import_modules
      module = importlib.import_module(name)
    File "/usr/lib64/python2.7/importlib/__init__.py", line 37, in import_module
      __import__(name)
    File "/usr/lib/python2.7/site-packages/dnf-plugins/system_upgrade.py", line 46, in <module>
      _, P_ = translation(TEXTDOMAIN)
    File "/usr/lib/python2.7/site-packages/dnf-plugins/system_upgrade.py", line 42, in translation
      t = dnf.pycomp.gettext.translation(name, fallback=True)
  AttributeError: 'module' object has no attribute 'gettext'

That last line of code does not exist in dnf-plugin-system-upgrade-0.5.0.

Did you maybe try to install dnf-plugin-system-upgrade from source, or install a package from F22+?

I recommend you check the versions for the plugin subpackages:

  rpm -qa "python*-dnf-plugin-system-upgrade"

and reinstall those packages to get the correct code.
Comment 2 Paul Rutledge 2016-01-20 03:11:15 EST
(In reply to Will Woods from comment #1)

Hi Will,
  Thank you for the fast reply.
  I did a dnf upgade and then when it failed I did it from source.
  This was the output from rpm -qa "python*-dnf-plugin-system-upgrade"
    python2-dnf-plugin-system-upgrade-0.5.0-1.fc21.noarch
  When I tried to remove it said no such file or dir
  A dnf list showed python3-dnf-plugin-system-upgrade.noarch-0.5.0-1.fc21
  I removed that and dnf-plugin-system-upgrade-0.5.0-1.fc21.noarch
  I then did a dnf system upgrade and the plugin seemed to work
    ( the upgrade failed due to VirtualBox, I'm working on that)

  Thank you for your help, it was not a bug, just a dodgy system,
    although the RPM output is interesting.
  I don't know how to close the bug, can I leave that to you?

  Thank you again
  Paul

Note You need to log in before you can comment on or make changes to this bug.