Bug 1299175 - [abrt] WARNING: CPU: 4 PID: 725 at include/drm/drm_crtc.h:1577 drm_helper_choose_encoder_dpms+0x8a/0x90 [drm_kms_helper]() [drm_kms_helper]
[abrt] WARNING: CPU: 4 PID: 725 at include/drm/drm_crtc.h:1577 drm_helper_cho...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:ea52ad454310bbb729583cc112b...
:
: 1312758 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-16 20:01 EST by Karl Latiss
Modified: 2016-04-11 05:39 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-11 05:39:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
karl+rhbugzilla: needinfo-


Attachments (Terms of Use)
File: dmesg (88.19 KB, text/plain)
2016-01-16 20:01 EST, Karl Latiss
no flags Details

  None (edit)
Description Karl Latiss 2016-01-16 20:01:14 EST
Additional info:
reporter:       libreport-2.6.3
WARNING: CPU: 4 PID: 725 at include/drm/drm_crtc.h:1577 drm_helper_choose_encoder_dpms+0x8a/0x90 [drm_kms_helper]()
Modules linked in: rfcomm nfsv3 nfs_acl nfs lockd grace sunrpc fscache cmac xt_CHECKSUM ipt_MASQUERADE nf_nat_masquerade_ipv4 tun nf_conntrack_netbios_ns nf_conntrack_broadcast ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack ebtable_filter ebtable_nat ebtable_broute bridge stp llc ebtables ip6table_raw ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_mangle ip6table_security ip6table_filter ip6_tables iptable_raw iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack iptable_mangle iptable_security bnep fuse vmw_vsock_vmci_transport vsock vmw_vmci hp_wmi iTCO_wdt ppdev iTCO_vendor_support sparse_keymap snd_hda_codec_hdmi tpm_infineon intel_rapl iosf_mbi x86_pkg_temp_thermal coretemp vfat kvm_intel fat btusb btrtl btbcm snd_hda_codec_realtek
 btintel kvm bluetooth snd_hda_codec_generic crct10dif_pclmul crc32_pclmul snd_hda_intel crc32c_intel snd_hda_codec snd_hda_core snd_hwdep snd_seq rfkill joydev snd_seq_device snd_pcm i2c_i801 snd_timer parport_pc snd mei_me parport mei ie31200_edac soundcore shpchp edac_core lpc_ich tpm_tis tpm binfmt_misc hid_logitech_hidpp hid_logitech_dj nouveau mxm_wmi i2c_algo_bit drm_kms_helper ttm drm e1000e serio_raw ptp pps_core wmi fjes video
CPU: 4 PID: 725 Comm: kworker/4:3 Not tainted 4.3.3-300.fc23.x86_64 #1
Hardware name: Hewlett-Packard HP Compaq Pro 6300 SFF/339A, BIOS K01 v02.90 07/16/2013
Workqueue: events nvif_notify_work [nouveau]
 0000000000000000 000000004c8d6e35 ffff8807f80cfd10 ffffffff813a626f
 0000000000000000 ffff8807f80cfd48 ffffffff810a07c2 ffff8807f45c7000
 ffff8807f5f09600 ffff8807f62d3000 0000000000000003 ffff8807f62d13e8
Call Trace:
 [<ffffffff813a626f>] dump_stack+0x44/0x55
 [<ffffffff810a07c2>] warn_slowpath_common+0x82/0xc0
 [<ffffffff810a090a>] warn_slowpath_null+0x1a/0x20
 [<ffffffffa016c2ca>] drm_helper_choose_encoder_dpms+0x8a/0x90 [drm_kms_helper]
 [<ffffffffa016c3bb>] drm_helper_connector_dpms+0x4b/0x100 [drm_kms_helper]
 [<ffffffffa01d110d>] ? g94_aux_mask+0x8d/0xa0 [nouveau]
 [<ffffffffa02353bb>] nouveau_connector_hotplug+0x3b/0xb0 [nouveau]
 [<ffffffffa0196a77>] nvif_notify_work+0x27/0xa0 [nouveau]
 [<ffffffff8178109e>] ? _raw_spin_unlock_irqrestore+0xe/0x10
 [<ffffffff810b861d>] ? pwq_dec_nr_in_flight+0x4d/0xa0
 [<ffffffff810b8cde>] process_one_work+0x19e/0x3f0
 [<ffffffff810b8f7e>] worker_thread+0x4e/0x450
 [<ffffffff8177cf31>] ? __schedule+0x371/0x980
 [<ffffffff810b8f30>] ? process_one_work+0x3f0/0x3f0
 [<ffffffff810b8f30>] ? process_one_work+0x3f0/0x3f0
 [<ffffffff810bede8>] kthread+0xd8/0xf0
 [<ffffffff810bed10>] ? kthread_worker_fn+0x160/0x160
 [<ffffffff8178199f>] ret_from_fork+0x3f/0x70
 [<ffffffff810bed10>] ? kthread_worker_fn+0x160/0x160
Comment 1 Karl Latiss 2016-01-16 20:01:25 EST
Created attachment 1115531 [details]
File: dmesg
Comment 2 Alexey 2016-02-29 03:46:54 EST
*** Bug 1312758 has been marked as a duplicate of this bug. ***
Comment 3 poma 2016-02-29 08:31:08 EST
You are not authorized to access bug #1312758.

Most likely the bug has been restricted for internal development processes and we cannot grant access.

If you are a Red Hat customer with an active subscription, please visit the Red Hat Customer Portal for assistance with your issue

If you are a Fedora Project user and require assistance, please consider using one of the mailing lists we host for the Fedora Project.


"If you are a Red Hat customer ..." !?
Comment 4 poma 2016-02-29 08:46:06 EST
(In reply to Karl Latiss from comment #1)
> Created attachment 1115531 [details]
> File: dmesg

[    1.195062] nouveau 0000:01:00.0: NVIDIA GF119 (0d93c0a1)

This WARNING is still seen with 4.4 series,
e.g.
kernel-debug-{core,modules}-4.4.3-201.fc22.x86_64

but it is solved with 4.5 series,
e.g.
kernel-debug-{core,modules}-4.5.0-0.rc5.git0.2.fc24.x86_64

i.e. it is solved for quite some time,
see https://bugs.freedesktop.org/show_bug.cgi?id=92307#c34

Would you mind to confirm this is solved for your case too, or not.
Comment 5 Karl Latiss 2016-03-01 05:55:26 EST
I have not seen the warning for over a week (since I installed kernel-4.3.5-300.fc23.x86_64).
Comment 6 John Sauter 2016-03-01 08:06:59 EST
I also saw the warning vanish, but it returned with the update to kernel 4.4.2-301.fc23.x86_64 #1 in Fedora 23.
Comment 7 poma 2016-03-01 14:06:16 EST
(In reply to Karl Latiss from comment #5)
> I have not seen the warning for over a week (since I installed
> kernel-4.3.5-300.fc23.x86_64).

WARNING(s) goes with
kernel-debug-{core,modules} less than or equal to 4.4 series,
while S3(STR) RESUME or/and XRandR DPMS routine.

Note "debug" kernel/modules, -NOT- standard "nodebug" kernel/modules ;)

https://kojipkgs.fedoraproject.org//packages/kernel/
Comment 8 poma 2016-03-01 14:10:00 EST
(In reply to John Sauter from comment #6)
> I also saw the warning vanish, but it returned with the update to kernel
> 4.4.2-301.fc23.x86_64 #1 in Fedora 23.

WARNING(s) goes within particular case scenario, not randomly.
See reply to Karl.
Comment 9 Karl Latiss 2016-03-01 15:17:44 EST
OK, except when I reported this I wasn't running kernel-debug-{core,modules}.
Comment 10 Hans de Goede 2016-04-11 05:39:46 EDT
This bug is also tracked upstream here:
 https://bugs.freedesktop.org/show_bug.cgi?id=92307

And is fixed upstream by this commit:
https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=0a882cadbc63fd2da3994af7115b4ada2fcbd638

Which is in stable kernel 4.4.4 and later, F22+ is at 4.4.6, closing.

Note You need to log in before you can comment on or make changes to this bug.