Bug 129921 - ifup can't find /tmp/tmp, causing empty resolv.conf
ifup can't find /tmp/tmp, causing empty resolv.conf
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-08-14 05:12 EDT by Patrik Elmberg
Modified: 2014-03-16 22:47 EDT (History)
1 user (show)

See Also:
Fixed In Version: 7.62-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-19 01:44:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrik Elmberg 2004-08-14 05:12:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809

Description of problem:
For function set_hostname () in
/etc/sysconfig/network-scripts/network-functions.

        rsctmp=`mktemp /tmp/XXXXXX`;
-       /bin/cp -fp /etc/resolv.conf /tmp/$rsctmp
-       echo "search $domain" >> /tmp/$rsctmp
-       change_resolv_conf /tmp/$rsctmp
-       /bin/rm -f /tmp/$rsctmp
+       /bin/cp -fp /etc/resolv.conf $rsctmp
+       echo "search $domain" >> $rsctmp
+       change_resolv_conf $rsctmp
+       /bin/rm -f $rsctmp


NB! network-functions is a config file (rpm -qc initscripts), and is
not updated with rpm -Uvh.


Version-Release number of selected component (if applicable):
initscripts-7.61.1-1

How reproducible:
Always

Steps to Reproduce:
1. service network restart
2. cat /etc/resolv.conf
3.
    

Additional info:
Comment 1 Simone Gotti 2004-08-14 09:26:19 EDT
I was having your same problem (the network init script doesn't work
because it call ifup with the boot options) and I've corrected it in
the same way. I was posting a new bug but I've found this. 
Comment 2 Bill Nottingham 2004-08-19 01:44:31 EDT
Fixed in 7.62-1, thanks!

Note You need to log in before you can comment on or make changes to this bug.