Bug 1299219 - Impossible to see installed extensions or install another extension with Firefox
Impossible to see installed extensions or install another extension with Firefox
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: gnome-shell-extensions (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Florian Müllner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-17 08:32 EST by Couret Charles-Antoine
Modified: 2016-12-20 12:57 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-20 12:57:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Couret Charles-Antoine 2016-01-17 08:32:22 EST
Description of problem:
Since last update, If I go to https://extensions.gnome.org/, I can't install extensions and I can't see my installed extension on https://extensions.gnome.org/local/

Version-Release number of selected component (if applicable):
gnome-shell-extensions-3.18.3-1.fc23
firefox-43.0.3-1.fc23

How reproducible:
Go to https://extensions.gnome.org/local/ with Firefox and see if the list was displayed. The Gnome-Shell Integration extension on Firefox is always activated.

I don't have this problem with Epiphany browser.
Comment 1 Phil 2016-01-20 08:53:55 EST
Same here, selinux is blocking access:

dbus[1458]: avc:  denied  { send_msg } for msgtype=method_call interface=org.freedesktop.DBus.Properties member=GetAll dest=:1.15 spid=3154 tpid=1739 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=dbus 
firefox.desktop[3027]: (plugin-container:3154): GnomeShellBrowserPlugin-WARNING **: Failed to grab shell version.
dbus[1458]: avc:  denied  { send_msg } for msgtype=method_call interface=org.gnome.Shell.Extensions member=ListExtensions dest=:1.15 spid=3154 tpid=1739 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=dbus 
firefox.desktop[3027]: (plugin-container:3154): GnomeShellBrowserPlugin-WARNING **: Failed to retrieve extension list: GDBus.Error:org.freedesktop.DBus.Error.AccessDenied: An SELinux policy prevents this sender from sending this message to this recipient, 0 matched rules; type="method_call", sender=":1.60" (uid=1001 pid=3154 comm="/usr/lib64/firefox/plugin-container /usr/lib64/moz") interface="org.gnome.Shell.Extensions" member="ListExtensions" error name="(unset)" requested_reply="0" destination=":1.15" (uid=1001 pid=1739 comm="/usr/bin/gnome-shell ")

As a workaround, try disabling selinux (temporarily) using "setenforce 0".
Comment 2 Garrett Mitchener 2016-01-21 09:06:54 EST
Possibly related to bug 1299697
Comment 3 Couret Charles-Antoine 2016-03-08 14:56:16 EST
This bug is fixed now.
Comment 4 Couret Charles-Antoine 2016-03-27 07:54:54 EDT
Hum, this bug came back.
Firefox 45.0.1-2.fc24
selinux-policy 3.13.1-179.fc24
gnome-shell 3.20.0-1.fc24

No issue with epiphany browser.
Comment 5 Fedora End Of Life 2016-11-24 10:00:17 EST
This message is a reminder that Fedora 23 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 23. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '23'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 23 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 6 Fedora End Of Life 2016-12-20 12:57:23 EST
Fedora 23 changed to end-of-life (EOL) status on 2016-12-20. Fedora 23 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.