Bug 1299229 - Dell Inspiron, Fedora 22, and ImPS/2 Elantech Touchpad: no two finger functionality
Dell Inspiron, Fedora 22, and ImPS/2 Elantech Touchpad: no two finger functio...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
22
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-17 10:53 EST by James Mills
Modified: 2016-02-12 02:51 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-12 02:51:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of various commands gathering information (14.61 KB, text/plain)
2016-01-17 10:53 EST, James Mills
no flags Details
gnome gui mouse/touchpad settings (21.11 KB, image/png)
2016-01-17 10:54 EST, James Mills
no flags Details
dmesg (68.09 KB, text/plain)
2016-01-18 20:16 EST, James Mills
no flags Details

  None (edit)
Description James Mills 2016-01-17 10:53:32 EST
Created attachment 1115611 [details]
output of various commands gathering information

Description of problem:
No edge scrolling or two finger functionality available with detected device. Basic cursor movement and right/left click is working but no advanced features at all.

Version-Release number of selected component (if applicable):


How reproducible:
every boot.

Steps to Reproduce:
1. Fresh install of Fedora 23
2. Using gnome environment.


Actual results:
no advanced touchpad features available. GUI mouse settings does not show any advanced two finger options. libinput-debug-events does send output to the screen but not sure how to use that data.

Expected results:
ability to use edge scrolling or two finger functions on touchpad.

Additional info:
attaching a screen shot of the GUI mouse/touchpad settings window and output from:
uname -a
journalctl | grep -i touchpad
xinput
xinput list-props
lsmod
Comment 1 James Mills 2016-01-17 10:54 EST
Created attachment 1115612 [details]
gnome gui mouse/touchpad settings
Comment 2 Peter Hutterer 2016-01-17 16:28:20 EST
looks like the device isn't detected and initialized by the kernel, so it looks like a mouse device, not a touchpad. the evdev log shows that it's advertising relative coordinates.

Please attach your dmesg and the exact model number of your laptop.


Coincidentally, you filed this against libinput but the log shows you're not actually using libinput. not that it makes a difference until the kernel is fixed, but you'll need to install xorg-x11-drv-libinput to use libinput.
Comment 3 James Mills 2016-01-18 20:16 EST
Created attachment 1116012 [details]
dmesg
Comment 4 James Mills 2016-01-18 20:16:55 EST
Installed xorg-x11-drv-libinput and rebooted:

# dnf list *libinput*
Last metadata expiration check performed 0:08:16 ago on Mon Jan 18 17:58:44 2016.
Installed Packages
libinput.x86_64                               1.1.0-3.fc22              @updates
xorg-x11-drv-libinput.x86_64                  0.14.0-1.fc22             @updates
xorg-x11-drv-libinput-devel.x86_64            0.14.0-1.fc22             @updates
Available Packages
libinput.i686                                 1.1.0-3.fc22              updates 
libinput-devel.i686                           1.1.0-3.fc22              updates 
libinput-devel.x86_64                         1.1.0-3.fc22              updates 
xorg-x11-drv-libinput-devel.i686              0.14.0-1.fc22             updates


Relevant model information from dmidecode:

Handle 0x0001, DMI type 1, 27 bytes
System Information
        Manufacturer: Dell Inc.
        Product Name: Inspiron 13-7359
        Version: Not Specified
        Serial Number: XXXXXXX
        UUID: XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX
        Wake-up Type: Power Switch
        SKU Number: 06FD
        Family: Not Specified

dmesg attached
Comment 5 James Mills 2016-02-11 21:06:40 EST
After a recent software update everything with the touchpad is now working as expected. I am not sure what data to capture here but the following is the kernel I am now running with everything working on this laptop:

[root@fedora ~]# uname -a
Linux fedora.localdomain 4.3.4-200.fc22.x86_64 #1 SMP Mon Jan 25 13:37:15 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
Comment 6 Benjamin Tissoires 2016-02-12 02:51:23 EST
That's good news though we don't know why :)

Ideally, I'd like to see a dmesg of the working kernel (4.3.4-200) to understand why your touchpad is now in the correct setting. There has been no changes in the elantech (PS/2) driver since v4.2 that would explain this, so I think it should be now handled over I2C.

Anyway, marking the bug as closed now that everything is working.

Note You need to log in before you can comment on or make changes to this bug.