Bug 129923 - [AGP] /sbin/loader panics when installing from non-onboard video
[AGP] /sbin/loader panics when installing from non-onboard video
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-14 06:16 EDT by Dan Hollis
Modified: 2015-01-04 17:08 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 03:30:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Hollis 2004-08-14 06:16:56 EDT
Description of problem:
Shuttle SB52G2 (http://eu.shuttle.com/sb52g2.htm)
p4/2600
512mb pc2100 ddr
geforce fx5200 in pci slot 2

Version-Release number of selected component (if applicable):
fedora core 3 test 1

How reproducible:
always

Steps to Reproduce:
1.install PCI video card (eg geforce fx5200)
2.setup bios to boot off PCI card instead of onboard intel agp video
3.watch installer blow up

Actual results:
/sbin/loader panics and the install halts

Expected results:
it should not panic :P

Additional info:
it appears /sbin/loader is trying to setup onboard video anyway, even
though it's been disabled in bios? if i boot off onboard video it's
ok. but the onboard video sucks, which is why i installed a geforce
fx5200 into one of the pci slots.
Comment 1 Arjan van de Ven 2004-08-14 06:24:11 EDT
any info besides "panics" ???
we have very little to go on here...
Comment 2 Dan Hollis 2004-08-14 10:31:02 EDT
looks basically exactly the same as #124007
Comment 3 Dave Jones 2004-12-08 01:50:21 EST
did this get fixed for fc3 final ?
Comment 4 Dan Hollis 2004-12-08 02:08:13 EST
nope. looks like a bug in intel-agp.ko

it tries to setup agp even if it's disabled in bios, and panics the kernel.
intel-agp.ko should just bail out instead.

you can duplicate it on i82845G chipset (probably others too), just disable agp
in bios and try loading intel-agp.ko for nice fireworks and a panicked kernel.
Comment 5 Dave Jones 2004-12-08 02:17:04 EST
booting with agp=off should get you past the agp initialisation.
Can you paste the exact agp messages that show up in the 'crashes' case ?
Comment 6 Dan Hollis 2004-12-08 15:41:15 EST
agp=off does nothing, still crashes.

the oops backtrace when it crashes (copied by hand, since the kernel is hardlocked)

show_stack
show_registers
die
do_page_fault
error_code
apic_timer_interrupt
agp_backend_initialize [agpgart]
agp_add_bridge
pci_device_probe_static
__pci_device_probe
pci_device_probe
bus_match
driver_attach
bus_add_driver
driver_register
pci_register_driver
init_module [intel_agp]
sys_init_module
sysenter_past_esp
Comment 7 Dan Hollis 2005-05-04 06:01:17 EDT
repeated attempts over several months to contact the kernel developers
responsible for this module have been fruitless.

maybe someone at redhat will have better luck.
Comment 8 Dave Jones 2005-07-15 16:42:14 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.