Bug 1299242 - Network Validation fails with IPv6 on the ping tests
Network Validation fails with IPv6 on the ping tests
Status: CLOSED DUPLICATE of bug 1298198
Product: Red Hat OpenStack
Classification: Red Hat
Component: os-net-config (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: RHOS Maint
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-17 12:50 EST by Attila Darazs
Modified: 2016-04-18 03:15 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-19 05:58:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Attila Darazs 2016-01-17 12:50:40 EST
Description of problem:

Network validation during overcloud deployment fails with multiple ping errors like this:

01:20:22.347 stdout: {
01:20:22.347   "status": "FAILED", 
01:20:22.347   "server_id": "c64e0c01-9db8-460b-89ff-e63d9eb33e92", 
01:20:22.347   "config_id": "e24758a4-c991-44c6-9ddb-19c4caca6d2c", 
01:20:22.347   "output_values": {
01:20:22.347     "deploy_stdout": "Trying to ping fd00:fd00:fd00:2000:f816:3eff:fec5:4ca4 for local network fd00:fd00:fd00:2000::/64...FAILURE
01:20:22.347 ", 
01:20:22.347     "deploy_stderr": "fd00:fd00:fd00:2000:f816:3eff:fec5:4ca4 is not pingable. Local Network: fd00:fd00:fd00:2000::/64
01:20:22.347 ", 
01:20:22.347     "deploy_status_code": 1
01:20:22.347   }, 
01:20:22.347   "creation_time": "2016-01-17T16:51:40Z", 
01:20:22.347   "updated_time": "2016-01-17T16:52:17Z", 
01:20:22.347   "input_values": {}, 
01:20:22.347   "action": "CREATE", 
01:20:22.347   "status_reason": "deploy_status_code : Deployment exited with non-zero status code: 1", 
01:20:22.347   "id": "95cd202b-62f7-42fd-aecf-e52284cb08bf"
01:20:22.347 }

Version-Release number of selected component (if applicable):
7-director poodle 2016-01-17.1

How reproducible:
100%

Steps to Reproduce:
1. Deploy using IPv6

Actual results:

Failed ping tests. Note that logging into the overcloud, you can actually ping these addresses using ping6.

Expected results:

Passing ping tests.

Additional info:

We have a few theories for why this happens. Either we use the wrong ping (ping vs. ping6), or it could be that the validation runs very close to the time the addresses are added, so that they are in "tentative" state, not gotten through the Duplicate Address Detection (DAD).

If the problem is the latter, we might circumvent it by waiting a bit before the check, or disable DAD altogether on the interfaces with this command (probably):

sysctl -w net.ipv6.conf.all.accept_dad=0

http://www.tldp.org/HOWTO/Linux+IPv6-HOWTO/proc-sys-net-ipv6..html
Comment 3 Udi Shkalim 2016-01-17 13:05:22 EST
https://review.openstack.org/#/c/204806/
Comment 5 Marius Cornea 2016-01-19 05:58:43 EST

*** This bug has been marked as a duplicate of bug 1298198 ***

Note You need to log in before you can comment on or make changes to this bug.