Bug 1299253 - epmd doesn't support IPv6
epmd doesn't support IPv6
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: erlang (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
urgent Severity urgent
: z4
: 7.0 (Kilo)
Assigned To: John Eckersberg
Asaf Hirshberg
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-17 16:08 EST by John Eckersberg
Modified: 2016-02-18 11:10 EST (History)
6 users (show)

See Also:
Fixed In Version: erlang-R16B-03.10min.5.el7ost
Doc Type: Bug Fix
Doc Text:
The Erlang port mapper daemon (epmd) can now listen on IPv6 addresses. In addition, clients can now register and query epmd over IPv6. This, in turn, now allows Erlang clustering to work in an IPv6-only environment. Previously, epmd could only bind and listen on IPv4 addresses, thereby preventing the formation of Erlang clusters in IPv6-only environments.c
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 11:10:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Eckersberg 2016-01-17 16:08:15 EST
Description of problem:


Version-Release number of selected component (if applicable):
erlang-erts-R16B-03.10min.4.el7ost.x86_64

How reproducible:
Always

Steps to Reproduce:
[root@rhel7 ~]# epmd -daemon
[root@rhel7 ~]# ss -antp | grep epmd
LISTEN     0      128                       *:4369                     *:*      users:(("epmd",2376,3))
[root@rhel7 ~]# epmd -kill
Killed
[root@rhel7 ~]# epmd -address ::1
epmd: Sun Jan 17 15:54:26 2016: cannot parse IP address "::1"


Actual results:
Does not bind to IPv6 by default or if explicitly 

Expected results:
Should bind to both ipv4/6 by default, and able to parse and use ipv6 address for '-address' option

Additional info:
https://github.com/erlang/otp/pull/864
Comment 2 Asaf Hirshberg 2016-02-01 04:08:08 EST
Verified on 2016-01-21-1.

[root@overcloud-controller-0 ~]# ss -antp | grep epmd
LISTEN     0      128          *:4369                     *:*                   users:(("epmd",pid=7868,fd=3))
ESTAB      0      0      127.0.0.1:4369               127.0.0.1:41244               users:(("epmd",pid=7868,fd=5))
LISTEN     0      128         :::4369                    :::*                   users:(("epmd",pid=7868,fd=4))
Comment 5 errata-xmlrpc 2016-02-18 11:10:44 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0259.html

Note You need to log in before you can comment on or make changes to this bug.