Bug 1299296 - [abrt] python-setuptools: setup.py:6:<module>:ValueError: please use 'pytest' pypi package instead of 'py.test'
[abrt] python-setuptools: setup.py:6:<module>:ValueError: please use 'pytest'...
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: python-setuptools (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Infrastructure SIG
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:edc8c1845169c34a5a77d4a48c2...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-17 20:53 EST by hmd
Modified: 2016-07-19 14:39 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-19 14:39:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (9.72 KB, text/plain)
2016-01-17 20:53 EST, hmd
no flags Details
File: environ (3.41 KB, text/plain)
2016-01-17 20:53 EST, hmd
no flags Details

  None (edit)
Description hmd 2016-01-17 20:53:52 EST
Version-Release number of selected component:
python-setuptools-17.1.1-3.fc22

Additional info:
reporter:       libreport-2.6.3
cmdline:        /usr/bin/python /usr/bin/easy_install py.test
dso_list:       python-libs-2.7.10-8.fc22.x86_64
executable:     /usr/bin/easy_install
kernel:         4.2.6-201.fc22.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
#1 <module> in /tmp/easy_install-oIBvRQ/py.test-0.0/setup.py:6
#2 _execfile in /usr/lib/python2.7/site-packages/setuptools/sandbox.py:46
#3 runner in /usr/lib/python2.7/site-packages/setuptools/sandbox.py:236
#4 run in /usr/lib/python2.7/site-packages/setuptools/sandbox.py:267
#5 run_setup in /usr/lib/python2.7/site-packages/setuptools/sandbox.py:237
#6 setup_context in /usr/lib/python2.7/site-packages/setuptools/sandbox.py:193
#7 save_modules in /usr/lib/python2.7/site-packages/setuptools/sandbox.py:152
#8 resume in /usr/lib/python2.7/site-packages/setuptools/sandbox.py:139
#9 save_modules in /usr/lib/python2.7/site-packages/setuptools/sandbox.py:164
#10 __exit__ in /usr/lib64/python2.7/contextlib.py:35
Comment 1 hmd 2016-01-17 20:53:58 EST
Created attachment 1115721 [details]
File: backtrace
Comment 2 hmd 2016-01-17 20:53:59 EST
Created attachment 1115722 [details]
File: environ
Comment 3 Kevin Fenzi 2016-01-18 16:14:01 EST
Can you please attach py.test?

did this work in the past?
Comment 4 Robert Kuska 2016-01-19 02:14:05 EST
py.test is just a dummy package on PyPI, you should install pytest instead.

See

https://pypi.python.org/pypi/py.test

https://github.com/pytest-dev/pytest/commit/883b3ca2c195d2a3dbaad85e25879a21df68ddbb

Therefore reported output is expected.
Comment 5 Fedora End Of Life 2016-07-19 14:39:51 EDT
Fedora 22 changed to end-of-life (EOL) status on 2016-07-19. Fedora 22 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.