Bug 1299306 - avc: denied { recvfrom } ...
avc: denied { recvfrom } ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy (Show other bugs)
6.8
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Lukas Vrabec
Milos Malik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-17 22:43 EST by xmu
Modified: 2017-03-21 05:44 EDT (History)
8 users (show)

See Also:
Fixed In Version: selinux-policy-3.7.19-294.el6
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-21 05:44:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description xmu 2016-01-17 22:43:19 EST
Description of problem:
When I tested bz1293247, and ran some AF_UNIX regression bugs, find avc failed.
the job is: https://beaker.engineering.redhat.com/jobs/1192004
the log is :test_log-Setup-avc.log
Info: Searching AVC errors produced since 1452847980.31 (Fri Jan 15 03:53:00 2016)
Searching logs...
Running '/usr/bin/env LC_ALL=en_US.UTF-8 /sbin/ausearch -m AVC -m USER_AVC -m SELINUX_ERR -ts 01/15/2016 03:53:00 < /dev/null >/mnt/testarea/tmp.rhts-db-submit-result.XSZsU5 2>&1'
----
time->Fri Jan 15 03:53:00 2016
type=SYSCALL msg=audit(1452847980.547:43): arch=c000003e syscall=42 success=yes exit=0 a0=3 a1=7ffc5a9152a0 a2=10 a3=9 items=0 ppid=7179 pid=7204 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="rhts-test-check" exe="/usr/bin/python" subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 key=(null)
type=AVC msg=audit(1452847980.547:43): avc:  denied  { recvfrom } for  pid=7204 comm="rhts-test-check" saddr=127.0.0.1 src=55415 daddr=127.0.0.1 dest=7084 netif=lo scontext=system_u:object_r:netlabel_peer_t:s0 tcontext=system_u:object_r:node_t:s0 tclass=node
type=AVC msg=audit(1452847980.547:43): avc:  denied  { ingress } for  pid=7204 comm="rhts-test-check" saddr=127.0.0.1 src=55415 daddr=127.0.0.1 dest=7084 netif=lo scontext=system_u:object_r:netlabel_peer_t:s0 tcontext=system_u:object_r:netif_t:s0 tclass=netif
Fail: AVC messages found.
Checking for errors...
Using stronger AVC checks.
	Define empty RHTS_OPTION_STRONGER_AVC parameter if this causes any problems.
Running 'cat /mnt/testarea/tmp.rhts-db-submit-result.XSZsU5 | /sbin/ausearch -m AVC -m SELINUX_ERR'
Fail: AVC messages found.
Running 'cat %s | /sbin/ausearch -m USER_AVC >/mnt/testarea/tmp.rhts-db-submit-result.Ggb5R5 2>&1'
Info: No AVC messages found.
/bin/grep 'avc: ' /mnt/testarea/dmesg.log | /bin/grep --invert-match TESTOUT.log
No AVC messages found in dmesg
Running '/usr/sbin/sestatus'
SELinux status:                 enabled
SELinuxfs mount:                /selinux
Current mode:                   permissive
Mode from config file:          enforcing
Policy version:                 24
Policy from config file:        targeted
Running 'rpm -q selinux-policy || true'
selinux-policy-3.7.19-287.el6.noarch

Version-Release number of selected component (if applicable):
selinux-policy-3.7.19-287.el6.noarch

How reproducible:

Steps to Reproduce:
run this job: https://beaker.engineering.redhat.com/jobs/1192004
1.change the "/distribution/kernelinstall" to which you want to test.
2.run the test


Actual results:
avc fail

Expected results:
avc pass

Additional info:
kernel 2.6.32-592.el6.x86_64 has no this issue: https://beaker.engineering.redhat.com/jobs/1192108
kernel 2.6.32-603.el6.x86_64 has this issue:
https://beaker.engineering.redhat.com/jobs/1193478
kernel 2.6.32-573.19.1.el6.x86_64 has this issue: https://beaker.engineering.redhat.com/jobs/1192004
Comment 2 Miroslav Grepl 2016-01-18 03:42:57 EST
We allow it in RHEL-7.

Could you try to add a local policy using

# ausearch -m avc -su netlabel_peer_t | audit2allow -M mypol
# semodule -i mypol.pp

Thank you.
Comment 15 Lukas Vrabec 2016-09-29 11:02:03 EDT
What is state of this BZ? Do we have any actual AVCs? 

Thanks.
Comment 16 Milos Malik 2016-09-29 11:03:56 EDT
I know only AVCs mentioned in comment#0 and comment#10.
Comment 24 errata-xmlrpc 2017-03-21 05:44:56 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0627.html

Note You need to log in before you can comment on or make changes to this bug.