Bug 1299341 - Updating a fencing device will sometimes result in it no longer being registered
Updating a fencing device will sometimes result in it no longer being registered
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pacemaker (Show other bugs)
7.2
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Ken Gaillot
cluster-qe@redhat.com
: ZStream
Depends On: 1287315
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-18 02:46 EST by Jan Kurik
Modified: 2016-02-16 06:18 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Prior to this update, if a user deleted an attribute from a fence device, Pacemaker's stonithd service sometimes mistakenly removed the entire device. Consequently, the cluster would no longer use the fence device. The underlying source code has been modified to fix this bug, and stonithd now properly distinguishes attribute removals from device removals. As a result, deleting a fence device attribute no longer removes the device itself.
Story Points: ---
Clone Of: 1287315
Environment:
Last Closed: 2016-02-16 06:18:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2016-01-18 02:46:31 EST
This bug has been copied from bug #1287315 and has been proposed
to be backported to 7.2 z-stream (EUS).
Comment 6 errata-xmlrpc 2016-02-16 06:18:03 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0216.html

Note You need to log in before you can comment on or make changes to this bug.