This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1299354 - (CVE-2016-0725) CVE-2016-0725 moodle: XSS vulnerability in course management search
CVE-2016-0725 moodle: XSS vulnerability in course management search
Status: NEW
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Product Security
impact=moderate,public=20160118,repor...
: Security
Depends On: 1299355 1299356
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-18 03:27 EST by Andrej Nemec
Modified: 2016-07-07 05:27 EDT (History)
1 user (show)

See Also:
Fixed In Version: moodle 3.0.2, moodle 2.9.4, moodle 2.8.10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrej Nemec 2016-01-18 03:27:41 EST
Search string in course management interface was not escaped when being output creating potential for XSS attack.

Original upstream report:

https://moodle.org/mod/forum/discuss.php?d=326206
Comment 1 Andrej Nemec 2016-01-18 03:28:14 EST
Created moodle tracking bugs for this issue:

Affects: fedora-all [bug 1299355]
Affects: epel-7 [bug 1299356]

Note You need to log in before you can comment on or make changes to this bug.