Bug 1299425 - [intservice_public_131] Failed to redirect to MASTER_PUBLIC_URL/console/redirect when logout Kibana console
[intservice_public_131] Failed to redirect to MASTER_PUBLIC_URL/console/redir...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging (Show other bugs)
3.1.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Jeff Cantrill
chunchen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-18 05:54 EST by chunchen
Modified: 2016-09-29 22:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-29 15:57:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
after_logout_page.png (51.63 KB, image/png)
2016-01-18 05:56 EST, chunchen
no flags Details

  None (edit)
Description chunchen 2016-01-18 05:54:34 EST
Description of problem:
It redirects to MASTER_PUBLIC_URL/console/logout when logout Kibana console, but not to  MASTER_PUBLIC_URL/console/redirect.

Version-Release number of selected component (if applicable):
[root@openshift-134 ~]# openshift version
openshift v3.1.1.4
kubernetes v1.1.0-origin-1107-g4c8e6f4
etcd 2.1.2

openshift3/logging-auth-proxy     cb2360f9f763
openshift3/logging-elasticsearch  d4c68f6c877e     
openshift3/logging-deployment     f260945c987d
openshift3/logging-kibana     d1bc2f361b4c
openshift3/logging-fluentd    05f86996004c

How reproducible:
always

Steps to Reproduce:
1. Deploy logging stack
2. Access Kibana console via browser:
https://$kibana-router

3. Logout the Kibana console via click the "Logout" link on the right top

Actual results:
It redirect to MASTER_PUBLIC_URL/console/logout

Expected results:
Should redirect to MASTER_PUBLIC_URL/console/redirect when logout Kibana console

Additional info:
Please refer to the attachment about that page
Comment 1 chunchen 2016-01-18 05:56 EST
Created attachment 1115800 [details]
after_logout_page.png
Comment 2 Jeff Cantrill 2016-01-18 09:30:31 EST
The redirect URL is customizable in the template and subsequent dc for kibana.  We can change the default if you feel 'redirect' is better, but speaking to liggit, not certain what the 'console/redirect' is or that it exists.
Comment 3 chunchen 2016-01-18 21:04:10 EST
Mark this bug as verified since the redirect URL is customizable.

Note You need to log in before you can comment on or make changes to this bug.