Bug 1299478 - Administration and Configuration Guide review
Administration and Configuration Guide review
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Grid 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.6.0
Unspecified Unspecified
unspecified Severity unspecified
: CR2
: 6.6.0
Assigned To: Christian Huffman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-18 08:24 EST by Martin Vrabel
Modified: 2016-07-13 19:00 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-17 13:56:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Vrabel 2016-01-18 08:24:51 EST
Document URL: 
http://docbuilder.usersys.redhat.com/23149/


Section Number and Name: 

Describe the issue: 

Suggestions for improvement: 

jmarkos: mcimbora ahojte, neviete ci nemala byt defaultna hodnota socket-timeout (SO_TIMEOUT) zmenena na -1 ? ... viem ze som niekde cital ze boli menene nejake timeouty na -1 aby sa vyhlo dvojznacnosti


17.1. Cache Loaders and Cache Writers

Issue: Add CacheWriter
CacheWriter is not mentioned

Suggestion: add
"CacheWriter is used to enforce entry passivation and activation on eviction in a cache."


-> AdvancedCacheLoader and AdvancedCacheWriter provide 
AdvancedCacheLoader and AdvancedCacheWriter provide operations to manipulate the UNDERLYING (not underlaying) storage in bulk: parallel iteration and purging of expired 


Procedure 17.1. Configure the Cache store Programatically -> 2. The passivation
MAYBE Issue: chagne passivation description
Suggestion: add -> if no secondary data store exists, then the object will only be removed from the in-memory cache.

17.2.4. About SKIP_CACHE_LOAD Flag
Suggestion: add  SKIP_CACHE_STORE and SKIP_SHARED_CACHE_STORE flags

17.4. Connection Factories 
Issue : SharedConnectionFactory is not mentioned

18.3. Cache Store Configuration Details (Remote Client-Server Mode)
The remote-store Element
Issue : ocket-timeout parameter sets whether the value defined in SO_TIMEOUT (in mill ... isnt the defaulkt -1 ? 	

The leveldb-store Element

Issue: The path parameter The directory within 

18.4.3. Migrating data from FileCacheStore to SingleFileCacheStore 

Issue: Change descrtiption 
suggestion: change Migrating data from FileCacheStore to SingleFileCacheStore 
 t o Upgrade JBoss Data Grid stores (format)

18.5. LevelDB Cache Store 
Suggestion: change "One directory stores the non-expired data and the second directory stores the expired keys before a purge. "
to 
"One directory stores the non-expired data and the second directory stores the keys pending to be purged permanently. "

18.5.1. Configuring LevelDB Cache Store (Remote Client-Server Mode)
Suggestion: Directories will be auto-created if it does not exit.

18.5.4. Configure a LevelDB Cache Store Using JBoss Operations Network -> Procedure 18.3. 

Issue:  Network 3.2 or better
Suggestion : Network 3.2 or higer/newer

18.9. Custom Cache Stores -> Procedure 18.10. Download JBoss Data Grid Source Code

Issue :  3 no the box labeled Red Hat JBoss Middleware, click the Download Software button. 
There is no box labeled "Red Hat JBoss Middleware" and no Donwload button, only Other Downloads -> Red Hat JBoss Middleware

 ⁠20.1.1. Write-Through Caching Benefits 

 Suggestion: REMOVE "his is at the cost of reduced performance for cache operations caused by the cache store accesses and updates during cache operations.:" 

ADD 
20.1.1. Write-Through Caching Disadvantages 
	Cost of reduced performance for cache operations caused by the cache store accesses and updates during cache operations. 

22.2.2. Download JBoss Operations Network 

Issue same as 18.5.4. -> There is no box labeled "Red Hat JBoss Middleware" and no Download button, only Other Downloads -> Red Hat JBoss Middleware

22.2.4. Download JBoss Operations Network (JON) Plugin
3. Click Downloads in the list under JBoss Enterprise Middleware. 

No label JBoss Enterprise Middleware

22.7.2.2. Manually Adding JBoss Data Grid Instances in Library Mode

Suggestion : REMOVE 22.7.2.2.1. Manually Adding JBoss Data Grid Instances in Library Mode

 ⁠A.4. JBoss Data Grid JGroups Configuration Files

 The following configuration files are included with JBoss Data Grid and contain the recommended values for JGroups:

 Suggestion: it could be mentioned that these files are in jboss-datagrid-x.x.x-library.zip -> infinispan-embedded-6.4.0.Final-redhat-1.jar

Additional information:
Comment 7 Christian Huffman 2016-02-17 13:56:15 EST
The Administration Guide has been updated and published; a link to the document on the customer portal is below:

  https://access.redhat.com/documentation/en-US/Red_Hat_JBoss_Data_Grid/6.6/html-single/Administration_and_Configuration_Guide/index.html

Note You need to log in before you can comment on or make changes to this bug.