Bug 1299494 - Env variables are not set for --new-chroot
Env variables are not set for --new-chroot
Status: CLOSED DUPLICATE of bug 1311796
Product: Fedora
Classification: Fedora
Component: mock (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Suchý
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-18 09:01 EST by Vít Ondruch
Modified: 2016-06-02 10:31 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-02 10:31:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vít Ondruch 2016-01-18 09:01:15 EST
Description of problem:
$ cat /etc/mock/cucos.cfg | grep RUBYOPT
config_opts['environment']['RUBYOPT'] = '-I/builddir/gem-cucos/lib/'

$ mock -r cucos shell --old-chroot
<mock-chroot>sh-4.3# env | grep RUBYOPT
RUBYOPT=-I/builddir/gem-cucos/lib/

$ mock -r cucos shell --new-chroot
sh-4.3# env | grep RUBYOPT





Version-Release number of selected component (if applicable):
$ rpm -q mock
mock-1.2.14-1.fc24.noarch


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
$ mock -r cucos shell --new-chroot
sh-4.3# env | grep RUBYOPT

Expected results:
$ mock -r cucos shell --new-chroot
sh-4.3# env | grep RUBYOPT
RUBYOPT=-I/builddir/gem-cucos/lib/


Additional info:
Comment 1 Vít Ondruch 2016-01-18 09:08:21 EST
Please note that --unpriv should be reflected as well.
Comment 2 Jan Kurik 2016-02-24 09:18:07 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 3 Miroslav Suchý 2016-06-02 10:31:31 EDT
This has been fixed in bug 1311796

*** This bug has been marked as a duplicate of bug 1311796 ***

Note You need to log in before you can comment on or make changes to this bug.