Bug 12995 - GCC/cc1 broken
Summary: GCC/cc1 broken
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
high
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard: Winston beta5
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-24 16:10 UTC by Suhaib Siddiqi
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-25 14:10:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Suhaib Siddiqi 2000-06-24 16:10:24 UTC
As I mentioned in my yesterday post, ld.so gives 

[root@hunda dx]# dx
BUG IN DYNAMIC LINKER ld.so: dl-version.c: 217: _dl_check_map_versions:
Assertion `needed != ((void *)0)' failed!

for some MOTIF 2.1.3 compiled applications. That is Beta-2 breaks binary
compability for some MOTIF 2.1.3 appliactions.

Now trying to recompile, I get 

make[3]: Entering directory `/root/dx/src/exec/dxmods'
gcc -DHAVE_CONFIG_H -I. -I. -I../../../include -I../../../include
-I./../dpexec -I/usr/include -I/usr/local/include -Dlinux 
-D_FILE_OFFSET_BITS=64 -I/usr/X11R6/include -I/usr/X11R6/include/X11  -g
-O2 -I/usr/X11R6/include -D_GNU_SOURCE -c _connectgrids.c
gcc: Internal compiler error: program cc1 got fatal signal 11
make[3]: *** [_connectgrids.o] Error 1
make[3]: Leaving directory `/root/dx/src/exec/dxmods'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/root/dx/src/exec'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/dx/src'
make: *** [all-recursive] Error 1


Looks like GCC 2.96 in Beta-2 is screwed up to.

Comment 1 Glen Foster 2000-07-18 19:14:52 UTC
This defect is considered MUST-FIX for Winston Beta-5

Comment 2 Erik Troan 2000-07-21 16:35:38 UTC
Please send us a test case for this.

Comment 3 Jakub Jelinek 2000-07-24 23:37:04 UTC
Please check gcc-2.96-41 and above if it is still reproducible, if yes,
add -save-temps -v command line options and send me
stdout and stderr output plus _connectgrids.i file.

Comment 4 Suhaib Siddiqi 2000-07-26 13:15:12 UTC
This bug not present any more in GCC 2.96 in Beta-4.  Therefore
I conclude it resolved.


Note You need to log in before you can comment on or make changes to this bug.