Bug 1299505 - gnome-calculator prints "Currency LTL is not provided by IMF or ECB" in Financial mode
gnome-calculator prints "Currency LTL is not provided by IMF or ECB" in Finan...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-calculator (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-18 09:25 EST by Jiri Prajzner
Modified: 2016-10-15 12:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-14 20:14:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Prajzner 2016-01-18 09:25:44 EST
Description of problem:
gnome-calculator prints "Currency LTL is not provided by IMF or ECB" in Financial mode

Version-Release number of selected component (if applicable):
3.18.2

How reproducible:
Always

Steps to Reproduce:
1. execute gnome-calculator
2. switch to Financial mode
3.

Actual results:
** (gnome-calculator:20713): WARNING **: currency.vala:407: Currency LTL is not provided by IMF or ECB

Expected results:
No warning printed out for LTL currency conversion

Additional info:
This is not dependent on whether the Financial mode has LTL set as the last used currency in a conversion. It seems to be set as an implicit default.
Comment 1 Zbigniew Jędrzejewski-Szmek 2016-10-13 10:30:46 EDT
$ GDK_BACKEND=wayland gnome-calculator

** (gnome-calculator:2198): CRITICAL **: number_reciprocal: assertion 'self != NULL' failed

** (gnome-calculator:2198): CRITICAL **: currency_set_value: assertion 'value != NULL' failed

** (gnome-calculator:2198): WARNING **: currency.vala:406: Currency IRR is not provided by IMF or ECB

$ rpm -qf /bin/gnome-calculator 
gnome-calculator-3.22.0-1.fc25.x86_64
Comment 2 Michael Catanzaro 2016-10-14 20:14:49 EDT
Fixed by https://git.gnome.org/browse/gnome-calculator/commit/?id=63d2f489897cbead3a7ded94b00209fced877b31 earlier this year

Will push a follow-up to remove the Iranian Rial.
Comment 3 Michael Catanzaro 2016-10-14 20:15:58 EDT
(In reply to Zbigniew Jędrzejewski-Szmek from comment #1)
> $ GDK_BACKEND=wayland gnome-calculator
> 
> ** (gnome-calculator:2198): CRITICAL **: number_reciprocal: assertion 'self
> != NULL' failed
> 
> ** (gnome-calculator:2198): CRITICAL **: currency_set_value: assertion
> 'value != NULL' failed

These are different bugs, please run it with G_DEBUG=fatal-criticals to get a nice backtrace can be reported via ABRT.
Comment 4 Michael Catanzaro 2016-10-14 20:24:41 EDT
(In reply to Zbigniew Jędrzejewski-Szmek from comment #1)
> ** (gnome-calculator:2198): WARNING **: currency.vala:406: Currency IRR is
> not provided by IMF or ECB

It's working now, maybe data for this currency was just temporarily missing? Or maybe it stopped trading? I have no clue what happened here.
Comment 5 Zbigniew Jędrzejewski-Szmek 2016-10-15 12:02:56 EDT
I cannot reproduce it now. I tried with network up and down, and no warnings are printed. I'll open a new issue if I see it again.

Note You need to log in before you can comment on or make changes to this bug.