Bug 1299517 - A removed package completely disappears from gnome-software lists
A removed package completely disappears from gnome-software lists
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: unetbootin (Show other bugs)
23
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kalpa Welivitigoda
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-18 10:02 EST by Ervin
Modified: 2016-04-08 07:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-08 07:50:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ervin 2016-01-18 10:02:20 EST
Description of problem:
I removed Unetbootin, not only was Unetbootin removed but it could not longer be found in gnome-software. I installed Unetbootin through gnome-software.

Version-Release number of selected component (if applicable):
 3.18.3

How reproducible:Not sure


Steps to Reproduce:
1.Search for Unetbootin in gnome-software
2.Install Unetbootin through gnome-software
3.Remove Unetbootin through gnome-software
4.Search for Unetbootin through gnome-software

Actual results:
After being removed Unetbootin can no longer be found in gnome-software, even after a reboot of the system. It looks like it's appdata is gone with it's removal as well. 

Expected results:
Unetbootin should not be removed from the gnome-software lists after being uninstalled if it is was initially present there, which in this case it was. 


Additional info:
I have not tested if the same thing happens when removing other apps that were initially installed with gnome-software. 
Also the gnome-software lists seem to change whenever where there is a new version of Fedora installed and the selection of apps in gnome-software is very limited compared to Yumex for example.
Comment 1 Richard Hughes 2016-01-19 04:23:34 EST
Are you sure you installed Unetbootin from gnome-software? Unetbootin does not have an AppData file and as such is not installable in the software center. Either upstream needs to add the file, or downstream can patch this in the srpm. See http://people.freedesktop.org/~hughsient/appdata/ for details.
Comment 2 Ervin 2016-04-08 07:50:31 EDT
Some installed packages from other software centers like yumex sometimes appear in the software center as installed. Even though their appdata is not there.

Note You need to log in before you can comment on or make changes to this bug.