Bug 129952 - Wireless link monitor applet always shows 100% signal quality
Wireless link monitor applet always shows 100% signal quality
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-applets (Show other bugs)
1
All Linux
medium Severity high
: ---
: ---
Assigned To: Mark McLoughlin
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-15 11:50 EDT by Daniel Roesen
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-16 04:15:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Roesen 2004-08-15 11:50:17 EDT
I'm using the prism54 driver for my NetGear WG511 card. This driver
reports statistics properly in /proc/net/wireless:

$ cat /proc/net/wireless
Inter-| sta-|   Quality        |   Discarded packets               |
Missed
 face | tus | link level noise |  nwid  crypt   frag  retry   misc |
beacon
  eth1: 0000  197.  194.  238.       0      0      0      0      0   
    0

The problem at hand is, that the wireless monitor applet calculates
the link quality percentage with a quality value range of 0..92 in
mind and does NOT check the range reported by the driver as it
should. The prism54 reports values up to ~250. As a result, the link
quality percentage displayed virtually never goes below 100%.

The problem is know to the GNOME folks:
http://bugzilla.gnome.org/show_bug.cgi?id=119472
but it seems that they are too bored to fix it properly. :-)

Can we have a local fix in Fedora? Above bug reports includes a
proposed patch.

$ rpm -q gnome-applets
gnome-applets-2.4.1-1

I guess the problem is also existent in FC2 and current rawhide,
so feel free to upgrade the report.
Comment 1 Mark McLoughlin 2004-08-16 04:15:01 EDT
As the upstream bug report suggest, the problem isn't an easy one, nor
is the patch workable since it will probably give worse results for
most cards.

The problem is relatively high on my priority list since the
gnome-netstatus applet has the same problem and I have a WG511 too,
but I'd prefer to track this upstream. No need to track the same
problem in two places.


  http://bugzilla.gnome.org/show_bug.cgi?id=119472


  

Note You need to log in before you can comment on or make changes to this bug.