Bug 1299524 - pulp-admin: dont break strings to new lines in various output
pulp-admin: dont break strings to new lines in various output
Status: CLOSED DUPLICATE of bug 1188781
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Pulp (Show other bugs)
6.1.5
x86_64 Linux
low Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-18 10:15 EST by Pavel Moravec
Modified: 2016-02-03 04:19 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-03 04:19:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Moravec 2016-01-18 10:15:37 EST
Description of problem:
Various output of pulp-admin (e.g. pulp-admin rpm repo list) aligns output to 80 characters. This makes troubles to copy&paste the details like repo id, and also makes troubles to any script relying on the output.

Please get rid of the alignment to 80 characters.


Version-Release number of selected component (if applicable):
pulp-admin-client-2.6.0.17-1.el7sat.noarch


How reproducible:
100%


Steps to Reproduce:
1. Install pulp-admin e.g. per https://access.redhat.com/solutions/1295653
2. pulp-admin rpm repo list
3. try any other command that can split some string to multiple lines


Actual results:
2. splits repo ID like:

Id:                  Default_Organization-Red_Hat_Enterprise_Linux_Server-Red_Ha
                     t_Satellite_Tools_6_1_for_RHEL_7_Server_RPMs_x86_64
Display Name:        Red Hat Satellite Tools 6.1 for RHEL 7 Server RPMs x86_64
Description:         None
Content Unit Counts:
  Erratum:       4
  Package Group: 1
  Rpm:           73



Expected results:
The output should be:

Id:                  Default_Organization-Red_Hat_Enterprise_Linux_Server-Red_Hat_Satellite_Tools_6_1_for_RHEL_7_Server_RPMs_x86_64
Display Name:        Red Hat Satellite Tools 6.1 for RHEL 7 Server RPMs x86_64
Description:         None
Content Unit Counts:
  Erratum:       4
  Package Group: 1
  Rpm:           73



Additional info:
Comment 2 Pavel Moravec 2016-02-03 04:19:58 EST

*** This bug has been marked as a duplicate of bug 1188781 ***

Note You need to log in before you can comment on or make changes to this bug.