Bug 1299531 - RoutingError :No route matches [GET] "/images/icons/new/event-request_vm_shelve_offload.png") when clicked on control->explorer
RoutingError :No route matches [GET] "/images/icons/new/event-request_vm_shel...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Eric Winchell
Matouš Mojžíš
error
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-18 10:24 EST by Aziza Karol
Modified: 2016-06-29 11:31 EDT (History)
6 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 11:31:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aziza Karol 2016-01-18 10:24:10 EST
Description of problem:


Version-Release number of selected component (if applicable):
5.5.2.1.20160114044944_395c086 

How reproducible:
100%

Steps to Reproduce:
1.Navigate to control->explorer
2.
3.

Actual results:
ActionController::RoutingError (No route matches [GET] "/images/icons/new/event-request_vm_shelve_offload.png") in production.log

Expected results:
No error

Additional info:
production.log:

[----] I, [2016-01-18T10:19:25.364779 #3004:557990]  INFO -- : Started GET "/images/icons/new/event-request_vm_shelve_offload.png" for 127.0.0.1 at 2016-01-18 10:19:25 -0500
[----] F, [2016-01-18T10:19:25.365838 #3004:557990] FATAL -- : 
ActionController::RoutingError (No route matches [GET] "/images/icons/new/event-request_vm_shelve_offload.png"):
  actionpack (4.2.5) lib/action_dispatch/middleware/debug_exceptions.rb:21:in `call'
  actionpack (4.2.5) lib/action_dispatch/middleware/show_exceptions.rb:30:in `call'
  railties (4.2.5) lib/rails/rack/logger.rb:38:in `call_app'
  railties (4.2.5) lib/rails/rack/logger.rb:22:in `call'
  actionpack (4.2.5) lib/action_dispatch/middleware/request_id.rb:21:in `call'
  rack (1.6.4) lib/rack/methodoverride.rb:22:in `call'
  rack (1.6.4) lib/rack/runtime.rb:18:in `call'
  activesupport (4.2.5) lib/active_support/cache/strategy/local_cache_middleware.rb:28:in `call'
  rack (1.6.4) lib/rack/lock.rb:17:in `call'
  actionpack (4.2.5) lib/action_dispatch/middleware/static.rb:116:in `call'
  actionpack (4.2.5) lib/action_dispatch/middleware/static.rb:116:in `call'
  rack (1.6.4) lib/rack/sendfile.rb:113:in `call'
  railties (4.2.5) lib/rails/engine.rb:518:in `call'
  railties (4.2.5) lib/rails/application.rb:165:in `call'
  rack (1.6.4) lib/rack/content_length.rb:15:in `call'
  thin (1.6.3) lib/thin/connection.rb:86:in `block in pre_process'
  thin (1.6.3) lib/thin/connection.rb:84:in `catch'
  thin (1.6.3) lib/thin/connection.rb:84:in `pre_process'
  thin (1.6.3) lib/thin/connection.rb:53:in `process'
  thin (1.6.3) lib/thin/connection.rb:39:in `receive_data'
  eventmachine (1.0.7) lib/eventmachine.rb:187:in `run_machine'
  eventmachine (1.0.7) lib/eventmachine.rb:187:in `run'
  thin (1.6.3) lib/thin/backends/base.rb:73:in `start'
  thin (1.6.3) lib/thin/server.rb:162:in `start'
  rack (1.6.4) lib/rack/handler/thin.rb:19:in `run'
  rack (1.6.4) lib/rack/server.rb:286:in `start'
  railties (4.2.5) lib/rails/commands/server.rb:80:in `start'
  railties (4.2.5) lib/rails/commands/commands_tasks.rb:80:in `block in server'
  railties (4.2.5) lib/rails/commands/commands_tasks.rb:75:in `tap'
  railties (4.2.5) lib/rails/commands/commands_tasks.rb:75:in `server'
  railties (4.2.5) lib/rails/commands/commands_tasks.rb:39:in `run_command!'
  railties (4.2.5) lib/rails/commands.rb:17:in `<top (required)>'
  bin/rails:4:in `require'
  bin/rails:4:in `<main>'
Comment 3 CFME Bot 2016-01-21 17:07:32 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/c39b94044b6b08e4ec518d932151aaaeff1e6865

commit c39b94044b6b08e4ec518d932151aaaeff1e6865
Author:     Eric Winchell <ewinchel@redhat.com>
AuthorDate: Wed Jan 20 15:38:50 2016 -0500
Commit:     Eric Winchell <ewinchel@redhat.com>
CommitDate: Wed Jan 20 16:21:51 2016 -0500

    missing image
    https://bugzilla.redhat.com/show_bug.cgi?id=1299531
    
    [slip ci]

 .../images/100/event-request_vm_shelve_offload.png       | Bin 0 -> 7180 bytes
 1 file changed, 0 insertions(+), 0 deletions(-)
 create mode 100644 app/assets/images/100/event-request_vm_shelve_offload.png
Comment 4 Matouš Mojžíš 2016-04-25 06:03:36 EDT
Verified in 5.6.0.4-beta2.3.20160421172650_719e256. No errors in production.log and I can find that image in source code of page when pressing ctrl + U.
Comment 6 errata-xmlrpc 2016-06-29 11:31:12 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.