Bug 1299557 - Update network with New Qos-Policy isn't working with SR-IOV agent
Update network with New Qos-Policy isn't working with SR-IOV agent
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
medium Severity high
: ---
: 8.0 (Liberty)
Assigned To: Miguel Angel Ajo
Itzik Brown
: Triaged, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-18 10:50 EST by Itzik Brown
Modified: 2016-06-29 09:59 EDT (History)
7 users (show)

See Also:
Fixed In Version: openstack-neutron-7.0.4-4.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 09:59:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1504166 None None None 2016-01-18 10:50 EST
OpenStack gerrit 285353 None None None 2016-05-05 04:43 EDT

  None (edit)
Description Itzik Brown 2016-01-18 10:50:04 EST
Description of problem:
When updating the QoS policy of a network the policy is not enforced when using SR-IOV and there is no indication in the agent's log.

Version-Release number of selected component (if applicable):
python-neutron-7.0.1-4.el7ost.noarch
openstack-neutron-7.0.1-4.el7ost.noarch
openstack-neutron-ml2-7.0.1-4.el7ost.noarch


How reproducible:


Steps to Reproduce:
1. Configure SRIOV and QoS
2. Create a network and a policy
3. Update the network with the new policy 
neutron net-update <network id/name> --qos-policy <policy id/name>

Actual results:


Expected results:


Additional info:
Comment 2 Assaf Muller 2016-03-28 08:04:21 EDT
@Miguel, can you help triage? Thank you.
Comment 3 Miguel Angel Ajo 2016-05-05 04:43:50 EDT
We have an U/S candidate patch for liberty (RHOSP8)
Comment 5 Itzik Brown 2016-06-29 04:41:42 EDT
Verified with openstack-neutron-7.0.4-7.el7ost.noarch
Comment 7 errata-xmlrpc 2016-06-29 09:59:15 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1353

Note You need to log in before you can comment on or make changes to this bug.