Bug 1299570 - Powertop or any other power-saving tool is neither provided nor run at boot by default
Powertop or any other power-saving tool is neither provided nor run at boot b...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: powertop (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Jaroslav Škarvada
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-18 11:25 EST by q8311692
Modified: 2016-01-19 05:01 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: Powersaving by default Reason: Save power and reduce noise emissions. Result: Lower power consumption, quieter computers, less heat emissions, lower energy bill, more competitive OS experience.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-19 05:01:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description q8311692 2016-01-18 11:25:26 EST
Description of problem: Powertop --autotune is not run by default, but has to be installed (dnf install powertop) and then activated by a terminal command (systemd enable powertop). This is too complicated for end-users, who wouldn't even know about powersaving or that powertop exists.


Version-Release number of selected component (if applicable): all


How reproducible: Boot a freshly installed Fedora


Steps to Reproduce:
1. Install Fedora
2. Boot

Actual results:
The system drains much too much power, since most or all power-saving options are not used.


Expected results:
All reasonable power-saving options should be enabled by default.


Additional info:
In my opionion, this is at least of medium importance. Without optimal power-saving, the user experience is severely degraded, especially in mobile situations. In static situations (desktop), the computer burns power unneccessary which leads to a high energy bill, a noisy computer due to fan upspinning and, in the long run, to unneccessary CO2 emmissions/pollution/energy waste/...
Comment 1 Jaroslav Škarvada 2016-01-19 05:01:09 EST
Thanks for the report.

Please note what is good for laptop users may be not good for servers. PowerTOP tunings can negatively affect performance/latency, moreover some of them are unsafe, can hang machine, and also they can cut off USB peripherals (mouse, keyboard). Blindly applying all these tunings on boot by default is really not good way to go for distribution. That's why PowerTOP upstream resisted too long to accept the --autotune patch. The right way is to go through all tunings one by one and apply them only if you know what you are doing. The more ugly approach is to run the PowerTOP service, check if everything is working as expected (if not, you can just reboot to fix things, because PowerTOP service doesn't run by default) and if it works for you, you can enable it to autostart.

We tried to keep Fedora kernel balanced to fit most users need. If you think there are some tunings which should be by default enabled in kernel, please file bug against kernel.

If you need to selectively enable some tunings on boot on your machine or make custom tunings, try 'tuned' package.

Regarding the autostart it is also out of my control. What is started by default is controlled by systemd presets from fedora-release package and need to be approved by FESCO (IIRC). But I am against such change.

Also I don't think PowerTOP should be installed in @minimal-environment group or @basic-desktop-environment. Maybe it could be installed in @workstation-product-environment, but it is out of my control. IMHO FESCO do such decisions. You need to open FESCO ticket.

Note You need to log in before you can comment on or make changes to this bug.