Bug 1299572 - Fix strict aliasing issue reported by rpmdiff
Fix strict aliasing issue reported by rpmdiff
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ConsoleKit (Show other bugs)
6.7
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Michal Sekletar
Robin Hack
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-18 11:26 EST by Michal Sekletar
Modified: 2016-05-10 20:59 EDT (History)
2 users (show)

See Also:
Fixed In Version: ConsoleKit-0.4.1-5.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 20:59:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0942 normal SHIPPED_LIVE ConsoleKit bug fix update 2016-11-24 18:09:27 EST

  None (edit)
Description Michal Sekletar 2016-01-18 11:26:38 EST
Description of problem:

Type pun (strict-aliasing) warning seen in all architectures build log:
    395  ck-log-system-start.c: In function 'main':
    396  ck-log-system-start.c:198: warning: dereferencing pointer 'e' does break strict-aliasing rules
    396  ck-log-system-start.c:198: warning: dereferencing pointer 'e' does break strict-aliasing rules
    397  ck-log-system-start.c:201: warning: dereferencing pointer 'e' does break strict-aliasing rules
Comment 5 errata-xmlrpc 2016-05-10 20:59:00 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0942.html

Note You need to log in before you can comment on or make changes to this bug.