Bug 1299592 - deployment fails tempest.scenario.test_network_basic_ops.TestNetworkBasicOps.test_network_basic_ops for bad floating_ip state
deployment fails tempest.scenario.test_network_basic_ops.TestNetworkBasicOps....
Status: CLOSED DUPLICATE of bug 1284739
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: chris alfonso
yeylon@redhat.com
: Automation, AutomationBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-18 12:26 EST by Steve Linabery
Modified: 2016-04-18 03:06 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-26 10:27:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Linabery 2016-01-18 12:26:09 EST
CI run against latest poodle passes deployment, but tempest fails tempest.scenario.test_network_basic_ops.TestNetworkBasicOps.test_network_basic_ops with this stacktrace:

Traceback (most recent call last):
  File "/home/stack/tempest/tempest/test.py", line 126, in wrapper
    return f(self, *func_args, **func_kwargs)
  File "/home/stack/tempest/tempest/scenario/test_network_basic_ops.py", line 395, in test_network_basic_ops
    self.check_public_network_connectivity(should_connect=True)
  File "/home/stack/tempest/tempest/scenario/test_network_basic_ops.py", line 203, in check_public_network_connectivity
    self.check_floating_ip_status(floating_ip, floatingip_status)
  File "/home/stack/tempest/tempest/scenario/manager.py", line 733, in check_floating_ip_status
    st=status))
  File "/usr/lib/python2.7/site-packages/testtools/testcase.py", line 348, in assertEqual
    self.assertThat(observed, matcher, message)
  File "/usr/lib/python2.7/site-packages/testtools/testcase.py", line 433, in assertThat
    raise mismatch_error
MismatchError: 'ACTIVE' != None: FloatingIP: <"FloatingIP" addr="10.8.149.62" id="2a8411da-6146-4a28-925f-812352e20aa6"> is at status: None. failed  to reach status: ACTIVE
Comment 4 Assaf Muller 2016-01-26 10:27:55 EST

*** This bug has been marked as a duplicate of bug 1284739 ***

Note You need to log in before you can comment on or make changes to this bug.