Bug 1299604 - ERROR: openstack Failed to parse: 2001:db8:fd00:1000:f816:3eff:fef3:5451:8774
ERROR: openstack Failed to parse: 2001:db8:fd00:1000:f816:3eff:fef3:5451:8774
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: os-cloud-config (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity high
: y3
: 7.0 (Kilo)
Assigned To: Jay Dobies
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-18 13:07 EST by Marius Cornea
Modified: 2016-04-18 03:13 EDT (History)
6 users (show)

See Also:
Fixed In Version: os-cloud-config-0.2.8-13.el7ost
Doc Type: Bug Fix
Doc Text:
Keystone endpoint creation failed due to incorrectly parsed IPv6 addresses. This fix modifies the Keystone client creation mechanism to correctly parse IPv6 addresses. 'os-cloud-config' now creates Keystone endpoints successfully.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 11:50:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 269254 None None None 2016-01-18 15:26 EST

  None (edit)
Description Marius Cornea 2016-01-18 13:07:26 EST
Description of problem:
During post config the following error shows up:
ERROR: openstack Failed to parse: 2001:db8:fd00:1000:f816:3eff:fef3:5451:8774

| nova       | computev3     | regionOne                                                                                                  |
|            |               |   publicURL: http://2001:db8:fd00:1000:f816:3eff:fef3:5451:8774/v3                                         |
|            |               |   internalURL: http://2001:db8:fd00:1000:f816:3eff:fef3:5451:8774/v3                                       |
|            |               |   adminURL: http://2001:db8:fd00:1000:f816:3eff:fef3:5451:8774/v3                           

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-0.8.6-105.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy ipv6 enabled overcloud 

Actual results:
Deploying templates in the directory /home/stack/templates/my-overcloud
The following cert files already exist, use --rebuild to remove the existing files before regenerating:
/etc/keystone/ssl/certs/ca.pem already exists
/etc/keystone/ssl/private/signing_key.pem already exists
/etc/keystone/ssl/certs/signing_cert.pem already exists
Connection to 192.0.2.8 closed.
ERROR: openstack Failed to parse: 2001:db8:fd00:1000:f816:3eff:fef3:5451:8774


Expected results:
No error shows up.
Comment 3 Emilien Macchi 2016-01-18 14:47:48 EST
slagle pointed out on IRC that https://github.com/openstack/os-cloud-config/blob/master/os_cloud_config/keystone.py#L346 is the code that manage endpoints in OSP7.

The {host} value does not contain brackets when running IPv6, which is the bug here.
James is working on a patch in os-cloud-config to add brackets when the IP is v6.
Comment 6 errata-xmlrpc 2016-02-18 11:50:17 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0264.html

Note You need to log in before you can comment on or make changes to this bug.