Bug 129961 - mutt never connects with new sasl2 patch
Summary: mutt never connects with new sasl2 patch
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: mutt (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC3Blocker
TreeView+ depends on / blocked
 
Reported: 2004-08-15 20:16 UTC by Gary Peck
Modified: 2014-03-17 02:47 UTC (History)
3 users (show)

Fixed In Version: 1.4.1-10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-15 23:51:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gary Peck 2004-08-15 20:16:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040723 Firefox/0.9.2

Description of problem:
Since upgrading to mutt-1.4.1-9, I haven't been able to connect to my
IMAP server. More specifically, I'm connecting to the imaps port. The
SSL connection goes fine, and mutt prompts me for my password. I enter
it, and the status line says "Authenticating (SASL)..." for a really
long time. Eventually, this goes away to be replaced with "Selecting
inbox...". mutt never gets past this stage.

Version-Release number of selected component (if applicable):
mutt-1.4.1-9

How reproducible:
Always

Steps to Reproduce:
1. Connect to an imaps://.../ mailbox from mutt
2.
3.
    

Actual Results:  The program stays at "Selecting inbox..." forever.

Expected Results:  A message list from the inbox.

Additional info:

Running mutt-1.4.1-8 works fine, as does recompiling mutt-1.4.1-9 with
the sasl2 patch disabled.

The server is running dovecot 0.99.10.9 on a Debian system.

Comment 1 Nalin Dahyabhai 2004-09-15 23:51:00 UTC
Please try again with 1.4.1-10, and reopen this bug if you find that
it still doesn't work (it should).

Comment 2 Bernhard Weisshuhn 2004-11-11 11:13:05 UTC
The same thing happens to me.
mutt-1.4.1-10 from fredora core 3, connecting to a cyrus-imapd-2.1.16
(not fedora).
SSL or TLS do not seem to make a difference.
If the correct password is given, mutt hangs.
If a wrong password is given, the authentication fails correctly, but
trying to reopen the inbox (typing 'c', '!' and enter) then segfaults.

Bug should be reopened, imho.



Note You need to log in before you can comment on or make changes to this bug.