Bug 1299612 - [Docs] [Director] Ceph journal partitions documentation is wrong
[Docs] [Director] Ceph journal partitions documentation is wrong
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity high
: ga
: 8.0 (Liberty)
Assigned To: Dan Macpherson
Radek Bíba
: Documentation, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-18 13:43 EST by Ben Nemec
Modified: 2016-09-21 14:15 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-21 14:15:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Nemec 2016-01-18 13:43:39 EST
Description of problem: Some incorrect information was initially provided to the docs for the release of 7.0, which resulted in Ceph deployments not automatically creating journal partitions.  As it turns out, it is possible to do Ceph configuration that creates journal partitions.  The sample configuration in section 6.3 currently looks like:

ceph::profile::params::osds:
        '/dev/sdc':
          journal: '/dev/sdb1'
        '/dev/sdd':
          journal: '/dev/sdb2'

And should instead be:

ceph::profile::params::osds:
        '/dev/sdc':
          journal: '/dev/sdb'
        '/dev/sdd':
          journal: '/dev/sdb'

Not specifying the partition number on the journal line allows the Ceph deployment code to create the necessary partitions at deploy time so it doesn't have to be done ahead of time.

Also, the note on https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/7/html/Director_Installation_and_Usage/sect-Overcloud_Requirements.html#sect-Ceph_Storage_Node_Requirements about journal partitions not being created should be removed.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Andrew Dahms 2016-02-07 22:43:02 EST
Assigning to Dan for review.
Comment 3 Dan Macpherson 2016-02-08 20:59:48 EST
Hi Ben,

We'd also have to modify the following warning too, right:

=== Important ===
The director does not create partitions on the journal disk. You must manually create these journal partitions before the Director can deploy the Ceph Storage nodes.

The Ceph Storage OSDs and journals partitions require GPT disk labels, which you also configure prior to customization. For example, use the following command on the potential Ceph Storage host to create a GPT disk label for a disk or partition:

# parted [device] mklabel gpt
=================
Comment 4 Ben Nemec 2016-02-09 13:24:38 EST
Yes, although it should be noted that the gpt part is still true (to my knowledge anyway), so that needs to stay.  Basically removing "The director does not create partitions on the journal disk. You must manually create these journal partitions before the Director can deploy the Ceph Storage nodes." is all that should be needed.
Comment 5 Dan Macpherson 2016-02-09 21:13:32 EST
Thanks, Ben!
Comment 8 Dan Macpherson 2016-05-02 23:38:45 EDT
Hi Ben,

This is anow a part of our dedicated Ceph Storage for OpenStack guide. It might be an idea to have a read through the scenario for deploying a Ceph cluster with the director:

https://access.redhat.com/documentation/en/red-hat-openstack-platform/8/red-hat-ceph-storage-for-the-overcloud/chapter-2-creating-an-overcloud-with-ceph-storage-nodes

The requirements of this BZ should be covered in 2.7. Mapping the Ceph Storage Node Disk Layout.

I should note there is a related BZ regarding incorrect documentation for the root disk hints:

https://bugzilla.redhat.com/show_bug.cgi?id=1330220

Apart from that, was there anything else in the Ceph Guide that requires a change?
Comment 9 Dan Macpherson 2016-05-12 20:34:16 EDT
Hi Ben, following up this BZ... Any further changes required?
Comment 10 Ben Nemec 2016-05-13 15:16:02 EDT
Sorry for the delay.  The new docs should take care of this bug.  I'm curious about the "This section does not apply to Ceph Storage nodes using dedicated journals." note at the bottom of 2.8 though.  You would still need to start with blank GPT disks whether or not you use dedicated journals, wouldn't you?
Comment 11 Andrew Dahms 2016-05-16 03:13:51 EDT
Assigning Radek as the QA contact.

Radek - could you take a look at the changes for this bug?
Comment 12 Radek Bíba 2016-05-30 08:08:59 EDT
I remember reading this content. Looks (still) good to me. However, adding needinfo from Dan due to Ben's question in comment 10 and leaving status ON_QA.
Comment 13 Dan Macpherson 2016-08-16 01:28:58 EDT
I did a scan and I think that the note from comment #10 was removed.

If there's nothing else, I'll close this bug as all changes have been currently released live.
Comment 14 John Fulton 2016-08-17 13:25:27 EDT
Dan,

I think you missed this document with the update. I just reloaded it: 

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/7/html-single/Director_Installation_and_Usage/index.html#sect-Advanced-Configuring_Ceph_Storage

But I still see hard coded partition numbers: 

~~~
    ceph::profile::params::osds:
        '/dev/sdc':
          journal: '/dev/sdb1'
        '/dev/sdd':
          journal: '/dev/sdb2'
~~~

As per Ben's first comment they should be removed in the above URL to be like: 

~~~
ceph::profile::params::osds:
        '/dev/sdc':
          journal: '/dev/sdb'
        '/dev/sdd':
          journal: '/dev/sdb'
~~~
Comment 16 Ben Nemec 2016-09-21 10:38:19 EDT
The OSD layout change looks good.  I'm still seeing the "IMPORTANT: This section does not apply to Ceph Storage nodes using dedicated journals." at the end of section 2.8 of https://access.redhat.com/documentation/en/red-hat-openstack-platform/8/red-hat-ceph-storage-for-the-overcloud/chapter-2-creating-an-overcloud-with-ceph-storage-nodes

That doesn't sound right to me.  Does Ceph not require GPT if you're using dedicated journal partitions?  I'm not aware of such a thing, but I'm hardly a Ceph expert.  Also, if that is true it seems like the IMPORTANT note should appear at the start of the section rather than the end.
Comment 17 Dan Macpherson 2016-09-21 10:56:44 EDT
Hey Ben,

I think the doc didn't publish correctly for OSP 8. I definitely made the change. Republishing now.
Comment 19 Ben Nemec 2016-09-21 12:34:19 EDT
Thanks, the OSP 8 docs look good now.

Glancing through the 7 docs though, I see we actually have two examples of the journal partitions and only one got changed.  There's a second instance in the storage-environment.yaml example below the one that was fixed.  We'll want to update that one too so they're consistent.
Comment 21 Ben Nemec 2016-09-21 12:59:43 EDT
Looks good, thanks.
Comment 22 Dan Macpherson 2016-09-21 14:15:53 EDT
Cool. Documentation currently publishing. I'll close out this BZ, but feel free to reopen if further changes are required to this section.

Note You need to log in before you can comment on or make changes to this bug.