Bug 1299648 - kpartx on multipath device returning before creation of dm partition device
kpartx on multipath device returning before creation of dm partition device
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
7.1
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Ben Marzinski
Lin Li
Steven J. Levine
: ZStream
Depends On: 1254692
Blocks: 1203710 1313485 1295577 1330480
  Show dependency treegraph
 
Reported: 2016-01-18 16:46 EST by Ben Marzinski
Modified: 2016-11-04 04:16 EDT (History)
13 users (show)

See Also:
Fixed In Version: device-mapper-multipath-0.4.9-87.el7
Doc Type: Bug Fix
Doc Text:
The `kpartx` tool no longer returns before devices are created Previously, by default the `kpartx` tool returned without waiting for devices to be created. This was a source of confusion for users who would expect the devices to exist immediately after `kpartx` returned. With this update, `kpartx` by default now waits until the devices are created before returning.
Story Points: ---
Clone Of: 1254692
: 1330480 (view as bug list)
Environment:
Last Closed: 2016-11-04 04:16:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Ben Marzinski 2016-02-26 17:41:09 EST
kpartx now runs it sync mode by default.
Comment 6 Lin Li 2016-04-25 07:32:22 EDT
Reproduced on device-mapper-multipath-0.4.9-77.el7
1). # rpm -qa | grep kpartx
    kpartx-0.4.9-77.el7.x86_64
2). # rpm -qa | grep multipath
device-mapper-multipath-libs-0.4.9-77.el7.x86_64
device-mapper-multipath-0.4.9-77.el7.x86_64
device-mapper-multipath-sysvinit-0.4.9-87.el7.x86_64
3). Execute script mentioned to reproduce
2+0 records in
2+0 records out
2147483648 bytes (2.1 GB) copied, 2.42782 s, 885 MB/s
sfdisk: Warning: /var/tmp/imgtst.img is not a block device

sfdisk: Disk /var/tmp/imgtst.img: cannot get geometry


Disk /var/tmp/imgtst.img: 261 cylinders, 255 heads, 63 sectors/track
sfdisk:  /var/tmp/imgtst.img: unrecognized partition table type

Old situation:
sfdisk: No partitions found

New situation:
Units: cylinders of 8225280 bytes, blocks of 1024 bytes, counting from 0

   Device Boot Start     End   #cyls    #blocks   Id  System
/var/tmp/imgtst.img1          0+    259     260-   2088449+  83  Linux
/var/tmp/imgtst.img2          0       -       0          0    0  Empty
/var/tmp/imgtst.img3          0       -       0          0    0  Empty
/var/tmp/imgtst.img4          0       -       0          0    0  Empty
Warning: no primary partition is marked bootable (active)
This does not matter for LILO, but the DOS MBR will not boot this disk.
Successfully wrote the new partition table


If you created or changed a DOS partition, /dev/foo7, say, then use dd(1)
to zero the first 512 bytes:  dd if=/dev/zero of=/dev/foo7 bs=512 count=1
(See fdisk(8).)
add map loop0p1 (253:5): 0 4176899 linear /dev/loop0 1
NO: 313085087
NO: 316822069
NO: 319848978
NO: 323203567
NO: 326373389
NO: 329500389
NO: 332653052
NO: 336869907
NO: 339931134
NO: 343157047
NO: 346240276
NO: 349212883
NO: 352183837
NO: 355079186
NO: 358050272
OK: 361472619



Verified on device-mapper-multipath-0.4.9-87.el7
1). # rpm -qa | grep kpartx
kpartx-0.4.9-87.el7.x86_64
2). # rpm -qa | grep multipath
device-mapper-multipath-0.4.9-87.el7.x86_64
device-mapper-multipath-sysvinit-0.4.9-87.el7.x86_64
device-mapper-multipath-libs-0.4.9-87.el7.x86_64
3). Execute script mentioned to reproduce
2+0 records in
2+0 records out
2147483648 bytes (2.1 GB) copied, 1.34744 s, 1.6 GB/s
sfdisk: Warning: /var/tmp/imgtst.img is not a block device

sfdisk: Disk /var/tmp/imgtst.img: cannot get geometry


Disk /var/tmp/imgtst.img: 261 cylinders, 255 heads, 63 sectors/track
sfdisk:  /var/tmp/imgtst.img: unrecognized partition table type

Old situation:
sfdisk: No partitions found

New situation:
Units: cylinders of 8225280 bytes, blocks of 1024 bytes, counting from 0

   Device Boot Start     End   #cyls    #blocks   Id  System
/var/tmp/imgtst.img1          0+    259     260-   2088449+  83  Linux
/var/tmp/imgtst.img2          0       -       0          0    0  Empty
/var/tmp/imgtst.img3          0       -       0          0    0  Empty
/var/tmp/imgtst.img4          0       -       0          0    0  Empty
Warning: no primary partition is marked bootable (active)
This does not matter for LILO, but the DOS MBR will not boot this disk.
Successfully wrote the new partition table


If you created or changed a DOS partition, /dev/foo7, say, then use dd(1)
to zero the first 512 bytes:  dd if=/dev/zero of=/dev/foo7 bs=512 count=1
(See fdisk(8).)
add map loop0p1 (253:5): 0 4176899 linear /dev/loop0 1
OK: 114357926



Test result: device mapper partition device is created prior to the kpartx command returning
Comment 12 errata-xmlrpc 2016-11-04 04:16:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2536.html

Note You need to log in before you can comment on or make changes to this bug.